cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

MSSQL Extension package error

SOLVED
Highlighted
Newbie

MSSQL Extension package error

Hi , Cant get enough on the following error, Any help please !

The extension  'MSSQL_ExtensionPackage'  version [1.0] must match the "major.minor.patch" pattern containing only integer values. Assuming a zero value for patch number. Please fix this in the metadata.xml file of the extension.

ThingWorx version : 7.1.2

Relation database connector from Market place .

MSSQL 2012

Thanks in advance !

1 ACCEPTED SOLUTION

Accepted Solutions

Re: MSSQL Extension package error

From the marketplace page,

Requirements:

ThingWorx 6.5.0, 6.6.2

SUPPORT

This item has been tested and certified by ThingWorx to successfully work with the ThingWorx platform, however this item is not currently supported by ThingWorx. By utilizing this item you acknowledge that the content is provided in ‘as-is’ condition and support will not be provided.

Alternatively to using that extension, you may

1) Look into this thread for the Correct answer post on how to set up jdbc driver: Using a third party Jar file for Database connection

2). Set up Thingworx 7.4 MSSQL version

View solution in original post

3 REPLIES 3

Re: MSSQL Extension package error

From the marketplace page,

Requirements:

ThingWorx 6.5.0, 6.6.2

SUPPORT

This item has been tested and certified by ThingWorx to successfully work with the ThingWorx platform, however this item is not currently supported by ThingWorx. By utilizing this item you acknowledge that the content is provided in ‘as-is’ condition and support will not be provided.

Alternatively to using that extension, you may

1) Look into this thread for the Correct answer post on how to set up jdbc driver: Using a third party Jar file for Database connection

2). Set up Thingworx 7.4 MSSQL version

View solution in original post

Re: MSSQL Extension package error

Hi , I get the same error when i import the extension i created ( 'SQLServerExtenstion'  version [1.0] must match the "major.minor.patch" pattern containing only integer value) . My metadata looks like below, (Structure lib/common/sqljdbc42.jar)

<Entities>

<ExtensionPackages>

<ExtensionPackage name="SQLServerExtenstion" description="MSSQL JDBC Extension" vendor="Created by Dinesh" packageVersion="1.0" minimumThingWorxVersion="5.0.0">

<JarResources>

<FileResource type="JAR" file="sqljdbc42.jar" description="MSSQL JDBC JAR"/>

</JarResources>

</ExtensionPackage>

</ExtensionPackages>

<ThingTemplates>

<ThingTemplate name="DBConnection" baseThingTemplate="Database" description="Database ThingTemplate"/>

</ThingTemplates>

</Entities>

FYI - My isConnection is True and lastConnection is current time

Re: MSSQL Extension package error

Please refer to my response above.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________