cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Platform Analytics (Property Transformation) + Anomaly detection Integration

sarjasalc
4-Participant

Platform Analytics (Property Transformation) + Anomaly detection Integration

Good afternoon.

 

Could you give me a hand with the following doubt?

 

I have been working with property transformations in Thingworx Platform Analytics.

I have an Azure VM with the following hardware configuration:

sarjasalc_0-1627336680068.png

 

I have installed the following components successfully:

 

+ TWX 9.x
+ Analytics Server
+ Platform Analytics
+ Vuforia Experience Service
+ Vuforia Studio
+ Kepware

 

In the installation of the Platform Analytics, I configure the Analytics server integration, and all the installation steps run successfully as shown below:

sarjasalc_7-1627338870347.png

 

Also, I followed all the steps to configure successfully the Property Transform Settings in ThingWorx, the RabbitMQ password encryption, and finally, I left by a defect the Property Transforms scalation.

 

sarjasalc_6-1627337974893.png

Using a dataset I emulated a remote device with a Pressure signal.

I used a timer to stream the pressure signal each 1, 10, 50, and 100 ms.

 

The pressure signal has the following form:

 

sarjasalc_1-1627336680096.png

 

I created three property transformations from the original pressure signal and all worked as expected:

sarjasalc_2-1627336680258.png

I configured an anomaly called PressureAnomaly, with the following parametrization:

 

sarjasalc_3-1627336871955.png

I did four tests transmitting the data at 1, 10, 50, and 100 ms separately, and the alert cannot complete all the steps outlined in the following diagram. All the times I tested the process only reach the calibrating state.

sarjasalc_4-1627337507642.png

 

I followed carefully all the steps that were described in the Thingworx documentation but all the processes finished in the seme calibrating state.

 

As a reference, the dataset has 60.000 pressure registers.

Also, I made another test with a modified version of the dataset that doesn't have anomalies and has 95.000 registers. I thought maybe If the signal doesn't have perturbations could pass for all the steps but as the other cases the state ends as calibrating

 

I really appreciate your help

 

1 ACCEPTED SOLUTION

Accepted Solutions

@sarjasalc ,

 

Thank you for posting your question to the PTC Community.

 

When you state that you have attempted to validate that your deployment of Anomaly Detection is working, did you perform the steps outlined in this Knowledge Article - How to Validate Anomaly Detection Configuration in ThingWorx?

 

Regards,

 

Neel

 

View solution in original post

5 REPLIES 5

@sarjasalc ,

 

Thank you for posting your question to the PTC Community.

 

When you state that you have attempted to validate that your deployment of Anomaly Detection is working, did you perform the steps outlined in this Knowledge Article - How to Validate Anomaly Detection Configuration in ThingWorx?

 

Regards,

 

Neel

 

View solution in original post

sarjasalc
4-Participant
(To:nsampat)

Good afternoon @nsampat @slangley 

 

Sorry for my missing response.

 

We ran some tests using the anomaly detection feature. The system detects some anomalies but we can detect some glitches in the functionality. Certainly, we don´t know if is something we are missing or if the training signal should have specific characteristics.

At the moment the Thingworx Analytics Server looks configured correctly and the anomalies as well, but we can't saw the expected behavior.

The flow that we couldn't make work is the property transformation with the anomaly detection feature.

@sarjasalc ,

 

Something of note, the AD with Property Transform intergration functionality was designed only for use in a Active-Active ThingWorx Cluster setup. Can you confirm if you are in a ThingWorx Cluster?

 

The integration you speak of is only for use in this infrastructure scenario, though since AD is working without cluster setup I believe this is not your use case. Details can be found here: https://support.ptc.com/help/thingworx/analytics/r9/en/index.html#page/analytics/analytics_install/a...

 

Regards,

 

Neel

sarjasalc
4-Participant
(To:nsampat)

Hi @nsamp

 

All the following features were installed in a VM on the same server

 

+ TWX 9.x
+ Analytics Server
+ Platform Analytics
+ Vuforia Experience Service
+ Vuforia Studio
+ Kepware

 

So I believe the cluster mode doesn't apply to our case.

slangley
23-Emerald I
(To:sarjasalc)

Hi @sarjasalc

 

If the previous response allowed you to find a solution, please mark it as the Accepted Solution for the benefit of others with the same issue.  If you still have questions, please let us know.

 

Regards.

 

--Sharon

Announcements