cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Radio Button Default State doesnt work for bindings

Highlighted
Newbie

Radio Button Default State doesnt work for bindings

Hi everyone,

I just created a radio button with two states, Name and ID, and i put the default at ID.

The selected text is bound to a Label and another thing.

What happens is that, with the default state set to ID (or Name, no importance), the default state is correctly selected, but the binding is not working. My Label is still set to nothing, and i have to manually click on the ID side of the button, even if it is already selected, to make it work.

I don't know if i am doing something wrong, or if this is a bug, but please let me know if you have a workaround.

Thanks !

Edit : I am using ThingWorx v7.4.0 b-159.

Ce message a été modifié par : Jules Dupas

4 REPLIES 4
Highlighted

Re: Radio Button Default State doesnt work for bindings

Jules, could you please state the exact version of ThingWorx you are working with?

Highlighted

Re: Radio Button Default State doesnt work for bindings

Oh, sorry, i'll edit my post.

I'm using 7.4.0 b-159.

Highlighted

Re: Radio Button Default State doesnt work for bindings

Thanks, I'll check that out and will report back.

Highlighted

Re: Radio Button Default State doesnt work for bindings

Jules it doesn't appear to be a bug rather a trigger issue. As you see when you first load the mashup there's nothing which is triggering the event to set the value to the label, however with your click event on the Radio button the value is set to the Label. Note this behaviour is also same in older versions. May be you can set the value with a service which loads with the mashup's first load to set the default value of the State which you are using in the Radio button.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!