cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Selected Row(s) of Open Street Map widget not working

Regular Member

Selected Row(s) of Open Street Map widget not working

I have an Open Street Map which i have bound to a table containing some alert information. The information includes a location - whenever an alert happens i add the information to the table and i can show the location using the map.

Now i would like to click on the map icon and see some more information about that particular asset. I'm trying to send one of the information fields to another service, like so:

OPENSTEETMAP QUERY.PNG

The tag i am trying to is 'AssetName' as seen above. But this does not appear to be working properly. I am using the Selected Row(s) ​event to execute the service that i receiving this 'AssetName' tag. But this is not working - I have tried to view the 'AssetName' output in a textbox widget but when i select an icon on the map there is nothing being populated into the textbox.

Any ideas on where i am going wrong?

3 REPLIES 3

Re: Selected Row(s) of Open Street Map widget not working

Hello, Andrew.

So, you bound the open street map to LPN thing (I assume using AssetLocation property) but then it says that  AssetName is not working. You can check the alert summary/history page or simply query the LPN thing to see values for AssetName property.

Also if you can attach an export of the mashup and LPN thing to better understand the design, that could prove useful.

Thanks,

-- Craig A.

Re: Selected Row(s) of Open Street Map widget not working

Hi Craig,

Thanks for your response. I have checked the alert logs are there is nothing relating in there.

I have attached both exports. Configuring the way i have done is the normal way for widgets to behave, i don't see where i am going wrong with this one.

Thanks!

Re: Selected Row(s) of Open Street Map widget not working

I have found that this functionality does not work for some other widgets including the List. Is there an outstanding issue on this?