cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Selection of row not working in Collection widget

PM_9712905
4-Participant

Selection of row not working in Collection widget

Hi,

I have created a base mashup and used in Collection widget, but I'm unable to select the rows that are rendered in the widget. I've enabled AllowSelection as well as AutoSelectFirstRow but still I'm unable to click on them. Even hovering color is not changing when I hover over the rows.

1 ACCEPTED SOLUTION

Accepted Solutions
c_lowy
13-Aquamarine
(To:PM_9712905)

Please find attached some example entities of a styled Collection widget. If you view the cwht_collection_mashup you will notice that it has cell, alternate cell and selected cell styles.

Are you able to see any difference between this configuration and yours that might help you understand why your styles are not displayed ?

View solution in original post

4 REPLIES 4
c_lowy
13-Aquamarine
(To:PM_9712905)

Hi @PM_9712905,

 

You might be in one of the situations described in the following article : Collection widget cell styles are not visible at runtime in ThingWorx. Could you try some of the workarounds described under "Resolution" ? 

PM_9712905
4-Participant
(To:c_lowy)

Hi @c_lowy , 

Thanks for the response. I checked for resolutions and I don't have any of the causes mentioned but still not working.

In base mashup I've a container with a state panel inside there are 3 labels and a ptc-icon which has no background color property. Panel or container are using default styles and I've some changes for font in label. That's it. And I've set height and width accordingly.

c_lowy
13-Aquamarine
(To:PM_9712905)

Please find attached some example entities of a styled Collection widget. If you view the cwht_collection_mashup you will notice that it has cell, alternate cell and selected cell styles.

Are you able to see any difference between this configuration and yours that might help you understand why your styles are not displayed ?

View solution in original post

PM_9712905
4-Participant
(To:c_lowy)

Thanks for the example. Sorry for the late reply.

I think it's a glitch in Thingworx 9.0, if we create the base mashup, collection widget from scratch, the rows are not clickable. I tried replicating the same as you gave in example in Twx 9.0, but somehow it's not clickable. I tried replicating in Twx 8.5, it works there.

I tried importing in Twx 9.0 it works fine and I used the same template for all services consisting of collection widget.

Announcements