cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

The Selected Text of a drop down widget in 8.5.2

SK_9531327
4-Participant

The Selected Text of a drop down widget in 8.5.2

The selected text of a dropdown widget is not showing up when the service used for the data field (dropdown) is triggered again after the mashup load. I have checked both the services output its working perfectly. I have binded the selected row of the service to a label widget so whenever there is a selected in the dropdown the label gets the data. But when the service for the dropdown is triggered in the middle (example using a button click) the selected text value goes away and the label no longer shows any data. Even if i open the dropdown box and select the same value it wont show up. Only if i change my selected, i can see the data back in the label widget

1 ACCEPTED SOLUTION

Accepted Solutions
SK_9531327
4-Participant
(To:slangley)

Hi-

 

Sorry but an upgrade is not an option for us any time soon. I have done a work around for this issue myself and it seems to work fine now. I used an expression as a middle layer between the two process. add some extra logic and it worked. 

 

Thanks.

View solution in original post

7 REPLIES 7

I think that's a bug in 8.5.2, I have similar use case running fine in 8.4.8 and 9.0. I checked on 8.5.2 and it is working as you described. 

slangley
23-Emerald I
(To:mnarang)

Hi @mnarang.

 

Have you created the jira for this community post?  Please provide the ticket number.

 

Thanks.

 

--Sharon

SK_9531327
4-Participant
(To:slangley)

Here is the ticket id C15601718 @slangley @mnarang 

Hi,

We also encountered the similar problem with List Widget and I believe it is fixed in TWX version 8.4.9.

Have a look to the release notes Version 8.4.9 Release Notes 

-Aditya

slangley
23-Emerald I
(To:SK_9531327)

Hi @SK_9531327.

 

From a review of the case, it will be necessary for you to upgrade to 8.5.9 or 9.0.  If you agree that this is the solution, please mark this post as the Accepted Solution for the benefit of others with the same issue.

 

Regards.

 

--Sharon

SK_9531327
4-Participant
(To:slangley)

Hi-

 

Sorry but an upgrade is not an option for us any time soon. I have done a work around for this issue myself and it seems to work fine now. I used an expression as a middle layer between the two process. add some extra logic and it worked. 

 

Thanks.

View solution in original post

slangley
23-Emerald I
(To:SK_9531327)

Hi @SK_9531327.

 

I'm glad you found an alternative solution.  For the benefit of others on the community, please mark your last post as the Accepted Solution.

 

Regards.

 

--Sharon

Announcements