cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

The menu does not show when I login not use the administrator account .

SOLVED

Re: The menu does not show when I login not use the administrator account .

The meun still can not be seen when I login not using the "Administrator" account.

But the other widgets can be shown normally.

The version of ThingWorx I am using  is Taiwan 6.0.

Is there a possibility that it is a bug of ThingWorx?

Re: The menu does not show when I login not use the administrator account .

Hi,

Is this the Run Time permission of your Menu ?

Re: The menu does not show when I login not use the administrator account .

Hi,

try to open the mashup in a private session in Chrome. Sometime, old cache keeps my mashup unchanged.

You could try to add the user to the Group Administrators. If it works, then remove from Administrators and add the user to the Organization ISI_Members. Sometime, adding user only to a group did not work for me, even the group is added to the organization.

Re: The menu does not show when I login not use the administrator account .

Looks like everything has been done and tried, so perhaps reset and check all the basics one more time.

1. the User is in a group.

2. the group is assigned to the Menu and the Menu item that needs to show.

3. the group has permission to run GetEffectiveMenu service of that particular menu

I believe that permissions to the platform subsystem may not be necessary , but just in case the group has permission to the PlatformSubsystem

Highlighted

Re: The menu does not show when I login not use the administrator account .

Hi, Maybe it's too late, but may someone come here later from google like I came.

I had the same issue, the solution was adding my user group to menu "Group Associations" , inside "Menu Definition"

Menu.png

View solution in original post

Re: The menu does not show when I login not use the administrator account .

Thanks this works

But i dont know if i also had to do all these steps before. So maybe all of them are necessary or just some of them.

Re: The menu does not show when I login not use the administrator account .

Thank you, this was the only piece of the puzzle that I was missing and to be honest, I would have never thought to look there as I forgot that the Menus also have group associations! 

Re: The menu does not show when I login not use the administrator account .

I believe this TS Article addresses this issue directly, it helped me figure out what was going on:

https://www.ptc.com/en/support/article?n=CS205546