cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ThingWorx on Postgresql cannot launch:Improper value found for model provider configuration password

SOLVED
Highlighted
Pearl

ThingWorx on Postgresql cannot launch:Improper value found for model provider configuration password

Hi,

I'm installing ThingWorx8.4 on Postgresql, but got error "Improper value found for model provider configuration password, system cannot start without valid password"  when launch tomcat.  I've executed 

 thingworxPostgresDBSetup.bat and thingworxPostgresSchemaSetup.bat without errors , so I'm sure that the password in the platform-settings.json is correct for the postgresql user "twadmin".   

 

If switch to H2 database , then tomcat can launch successfully and Thingworx application works well. 

 

Any suggestions ?   The tomcat error log and platform-settings for H2 and PostgreSQL are attached. 

==================Environment Information===============

ThingWorx version: 8.4

OS: Windows server 2012 R2

Tomcat: 9.0 

Database: PostgreSql 10

JDK: Oracle 1.8.0_192/64bit

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ThingWorx on Postgresql cannot launch:Improper value found for model provider configuration pass

Can you try with just this in platform-settings for postgres?

{
    "PlatformSettingsConfig": {
        "AdministratorUserSettings": {
            "InitialPassword": "Adminxxxxxx"
        },
		"LicensingConnectionSettings": {
			"username": "******",
			"password": "******",
			"timeout":"60"
		}
    },
   "PersistenceProviderPackageConfigs": {
"PostgresPersistenceProviderPackage": {
"ConnectionInformation": {
"jdbcUrl": "jdbc:postgresql://localhost:5432/thingworx", "password": "Adminxxxxxx", "username": "twadmin" } } } }

  

View solution in original post

1 REPLY 1

Re: ThingWorx on Postgresql cannot launch:Improper value found for model provider configuration pass

Can you try with just this in platform-settings for postgres?

{
    "PlatformSettingsConfig": {
        "AdministratorUserSettings": {
            "InitialPassword": "Adminxxxxxx"
        },
		"LicensingConnectionSettings": {
			"username": "******",
			"password": "******",
			"timeout":"60"
		}
    },
   "PersistenceProviderPackageConfigs": {
"PostgresPersistenceProviderPackage": {
"ConnectionInformation": {
"jdbcUrl": "jdbc:postgresql://localhost:5432/thingworx", "password": "Adminxxxxxx", "username": "twadmin" } } } }

  

View solution in original post