cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx 8.4 First Login failure post installation

SOLVED
Participant

Thingworx 8.4 First Login failure post installation

Hi,

We are facing issues with Thingworx first time login.

We are using - Thingworx 8.4 on Tomcat 9.x on Azure Windows Server 2012 VM. DB is Azure managed PostgreSQL 10.x

Please take a look at the attachment.

We tried all possible login credentials and nothing worked. Also tried Administrator/admin credentials from some community discussions.

What should be the first time login?

The online Thingworx documentations suggest that once we open "http://server:port/Thingworx" page, we should change the initial password that was defined in platform-settings.json. However, I am unable to get past this login page.

 

Requesting some assistance please.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Thingworx 8.4 First Login failure post installation

Hi Sharon,

Thanks for your response. I was able to resolve this issue.

I was mislead from some forum discussions and tried "admin" as default password for Administrator user name. Later I realized that the "Initial Password" configured in platform-settings.json itself is the Administrator password.

 

I am able to login now.

 

Thank you!

View solution in original post

2 REPLIES 2

Re: Thingworx 8.4 First Login failure post installation

Hi @nikhilsvaish.

 

Did you make the Administrator password at least 14 characters in length (set via the platform-settings.json file)?  If not, you will need to drop the database/tablespaces, then re-run the database creation scripts.

 

Regards.

 

--Sharon

Re: Thingworx 8.4 First Login failure post installation

Hi Sharon,

Thanks for your response. I was able to resolve this issue.

I was mislead from some forum discussions and tried "admin" as default password for Administrator user name. Later I realized that the "Initial Password" configured in platform-settings.json itself is the Administrator password.

 

I am able to login now.

 

Thank you!

View solution in original post