cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx Flow on EC2 without Domain

SOLVED
Highlighted
Granite

Thingworx Flow on EC2 without Domain

Hi,

I recently installed Thingworx Flow 8.5.0 on an EC2 instance (Red Hat) with the given installation-routine. If you want to enable https you have to type in a domain name during the installation which is then used when you access the platform.

 

Is there a way to use Thingworx Flow without a static domain/ip. Because the EC2 instance changes its public IP if restarted and then it's not usable anymore. I know that you can create a static IP for an EC2 instance, but that wouldn't help my use case here.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Thingworx Flow on EC2 without Domain

Hi,

 

After setting static hostname, you need either to modify all the conf files for Thingworx Flow with the name of instance (don't recommend as there are a lot of files and there is no procedure to guide you), either re-install flow with the hostname.domain.com . As far as I know, if TWX Flow server is not in a domain, then you cannot use connectors with Oauth (like Gmail, Box, Salesforce etc.)

 

Hope it helps,

Raluca Edu

View solution in original post

6 REPLIES 6
Highlighted

Re: Thingworx Flow on EC2 without Domain

Hi,

 

Please use the hostname of the instance, not the ip address. The hostname should be configured to persist on EC2 instance restart: https://aws.amazon.com/premiumsupport/knowledge-center/linux-static-hostname-rhel7-centos7/

 

Hope it helps,

Raluca Edu

Highlighted

Re: Thingworx Flow on EC2 without Domain

Hi, 

thanks for you reply.

 

I've set the static hostname now but it doesn't work. It is basically the same problem: I am trying to call my Thingworx-Instance with https://x.x.x.x/Thingworx which is working like expected so far... I'm getting the usual warning about my selfsigned certificate - nothing special.

But after I acknowledge this security warning the URL switches to https://<EnteredHostname>/Thingworx which of course doesn't work. So I just can access my instance if I'm entering the URL with my current IP on every step. But the configuration is set in a way, that it is always trying to use the hostname as a domain.

 

Furthermore I can't point out the exact file(s) where I can change this behaviour. I reinstall Thingworx every time to be safe...

Highlighted

Re: Thingworx Flow on EC2 without Domain

Hi,

 

After setting static hostname, you need either to modify all the conf files for Thingworx Flow with the name of instance (don't recommend as there are a lot of files and there is no procedure to guide you), either re-install flow with the hostname.domain.com . As far as I know, if TWX Flow server is not in a domain, then you cannot use connectors with Oauth (like Gmail, Box, Salesforce etc.)

 

Hope it helps,

Raluca Edu

View solution in original post

Highlighted

Re: Thingworx Flow on EC2 without Domain

I also suspected that the mandatory domain is related with the multiple connection-types that Flow offers. That means there is no easy solution to use flow with a dynamic IP.

 

Thank you!

Highlighted

Re: Thingworx Flow on EC2 without Domain

I also have Flow on a EC2 with Red Hat and and remote aws RDS.

I have used two options, 

The one we are using right now is using the internal ip address of the ec2 

The domain name of the ec2 does not work don't know why.

the second one, is using a Load Balancer and put the domain name of the load balancer in the configuration. this one also works.

 

Highlighted

Re: Thingworx Flow on EC2 without Domain

Hi @DanZ.

 

If the previous response allowed you to find a solution, please mark it as the Accepted Solution for the benefit of others with the same issue.

 

Regards.

 

--Sharon

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!