cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to open custom entities with non-admin user on ThingWorx Composer.

SOLVED
Highlighted
Aquamarine

Unable to open custom entities with non-admin user on ThingWorx Composer.

The entity is keep on stuck at "Loading" when opening with non-admin user.

 

The errors in application logs are:-

 

1) [context: com.thingworx.webservices.context.HttpExecutionContext@235c9b54][message: Entity Not Found : [GenericThing]]

2) [context: com.thingworx.webservices.context.HttpExecutionContext@6ee9a2ed][message: Entity Not Found : [SecurityServices]]

3) [context: com.thingworx.webservices.context.HttpExecutionContext@7e631cde][message: Entity Not Found : [PlatformSubsystem]]

4) [context: com.thingworx.webservices.context.HttpExecutionContext@7d96a4e4][message: Entity Not Found : [ConfiguredThing]]

 

What I did till now is as mentioned:-

1) One Normal user created

2) Assigned to one group

3) Made that group part of one org

4) Gave visibility permission to entire org

 

Please let me know what extra required to be done as I am stuck at this point?

 

The ThingWorx version is 8.3.13. 

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to open custom entities with non-admin user on ThingWorx Composer.

Hello @ranjank,

I would suggest to try putting in place the resolution of following article :  Resource/Subsystem permission issues for non-admin user from ThingWorx 8.0.0.
I hope this helps.

View solution in original post

2 REPLIES 2
Highlighted

Re: Unable to open custom entities with non-admin user on ThingWorx Composer.

Hello @ranjank,

I would suggest to try putting in place the resolution of following article :  Resource/Subsystem permission issues for non-admin user from ThingWorx 8.0.0.
I hope this helps.

View solution in original post

Highlighted

Re: Unable to open custom entities with non-admin user on ThingWorx Composer.

Hi @ranjank.

 

If the previous response allowed you to find a solution, please mark it as the Accepted Solution for the benefit of others with the same issue.

 

Thank you for your participation in our community!

 

Regards.

 

--Sharon

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!