cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Upgrading to 9.3 Script error

ndupreez
6-Contributor

Upgrading to 9.3 Script error

Upgrading from 9.2.3 to 9.3.4

 

Running script "update_postgres.sh" give the following error:

/root/Downloads/9.3.4/update/common_update_utils.sh: line 89: `common_update_utils::build_version_string': not a valid identifier

 

System info:

RHEL 8.6

PSQL v13.8

TOMCAT 9.0.52

JAVA 11.0.13

 

Any direction or advise will be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
ndupreez
6-Contributor
(To:nmilleson)

Hi Nick

 

Thank you for the question.

I was using "sh" to run the script.

 

It is working with "bash" ,

eg.  ./update_postgres.sh

 

If it still doesn't work, also remeber to make the scrip executable.

 

Kind Regards

Niel

View solution in original post

2 REPLIES 2

@ndupreez ,

 

Can you share the command you're using to run that script?  And just to be clear, you're on step "E" on this page, correct?

 

https://support.ptc.com/help/thingworx/platform/r9/en/index.html#page/ThingWorx/Help/Installation/Installation/manual_inplace_upgrade_windows_9.3.html#wwID0ELBUT

 

-Nick

ndupreez
6-Contributor
(To:nmilleson)

Hi Nick

 

Thank you for the question.

I was using "sh" to run the script.

 

It is working with "bash" ,

eg.  ./update_postgres.sh

 

If it still doesn't work, also remeber to make the scrip executable.

 

Kind Regards

Niel

Top Tags