cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Value Stream Question

Highlighted
Level 1

Value Stream Question

I am attempting to setup a value stream for my mashups so I can view historical data.  I have my value stream setup correctly based on the information I have found online.  I have my value stream linked to my thing template.

I setup my some of my properties to be logged as ALWAYS.  I have let the device push changing data values for a few hours.  However, I don't see any values when I run the service QueryPropertyHistory.  I see the values I setup to be logged, but no data is showing up.

The values I am trying to logged are info tables.  One parameter in the info table is being updated.  I am not sure if the save is being triggered or if I do not have something linked correctly.  Also, the parameter logging is being turned on/off via a script.  I didn't setup the logging when the parameter was initially configured.

Query Results

Value Stream Configuration

Thing information/configuration

I have also tried linking the value stream to the thing template as well as the thing itself to see if that was the issue.

6 REPLIES 6

Re: Value Stream Question

Paul, just to check, you have selected the 'Logged' Aspect for these properties right? Once you verify that, can you try manually changing one of these logged properties to see if it updates the stream?

Re: Value Stream Question

Is there any regular property that is being updated vs. Infotable items? I have never tried logging infotables into a ValueStream although I assume it should work.

Re: Value Stream Question

It turns out my remote thing hasn't been online yet so this maybe the root cause of my issues.  I am working on getting it up and running.

Re: Value Stream Question

I tried using the set command, but the thing I am working with is a remote thing.  Since it hasn't been connected I can't manually change the value.  Unless there is a way to do that.

Re: Value Stream Question

If it is a Remote Thing, you would need to get it connected first before trying to set values though.

Re: Value Stream Question

It's working now!

There were a few issues with the configuration I was using.  I didn't have the DataChange​ type set. When the thing was created it was set to unidentified.  I changed it to Always and set the logging to ON. 

Everything seems to be working great now.  Thanks for the help!