cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

connecting Azure IoT Hub to Thingworx through Thingworx Azure IoT Hub Connector

Mayur_Phase
3-Visitor

connecting Azure IoT Hub to Thingworx through Thingworx Azure IoT Hub Connector

Hi,

   I am trying to connect  azure Iot hub to thingworx platform using this link:

   https://developer.thingworx.com/en/resources/guides/azure-iot-hub-connector-quickstart

  1. This tutorial is given with java code. I want to use .net to start connection server with thingworx platform.               How do I do this? 

   2. Also, I tried to start connection server but getting following error:

 

       Caused by: com.typesafe.config.ConfigException$IO: C:\Thingworx-Azure-IoT-Hub-Connector-2.0.0.141\connector\conf\azure-iot.conf-Dlogback.configurationFile=C:\Thingworx-Azure-IoT-Hub-Connector-2.0.0.141\connector\conf\logback.xml: java.io.FileNotFoundException: C:\Thingworx-Azure-IoT-Hub-Connector-2.0.0.141\connector\conf\azure-iot.conf-Dlogback.configurationFile=C:\Thingworx-Azure-IoT-Hub-Connector-2.0.0.141\connector\conf\logback.xml (The filename, directory name, or volume label syntax is incorrect)

 

 Please provide your guidance.

9 REPLIES 9

Hello @Mayur_Phase,

 

For your error -- just add a space between "conf" and "-D", so that it reads like that:

 

...connector\conf\azure-iot.conf -Dlogback.configurationFile...

 

/ Constantine

Thank you for your reply. I made a change as you mentioned.
Now I am getting following error log:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by
com.google.inject.internal.cglib.core.$ReflectUtils$1
(file:/C:/Thingworx-Azure-IoT-Hub-Connector-2.0.0.141/connector/lib/guice-4.1.0.jar)
to method
java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
WARNING: Please consider reporting this to the maintainers of
com.google.inject.internal.cglib.core.$ReflectUtils$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal
reflective access operations
WARNING: All illegal access operations will be denied in a future release

Please provide the guidance.

There are no errors in your example, only warnings. You can probably ignore those, as soon as it works.

 

/ Constantine

Thank you for your response.

As these are warnings, I checked for connection server that should get started after running azure-iot.bat command but unable see any connection server that is started here. (followed path to check server connection: thingworx foundation⇾monitoring⇾connection servers).

Please have a look.

 

 

slangley
23-Emerald I
(To:Mayur_Phase)

Hi @Mayur_Phase.

 

Please advise the version of ThingWorx you are running.  If you're running ThingWorx 8.5+, you'll need to update to the latest version of the ThingWorx Azure IoT Hub Connector:

 

 

If you're running a version of ThingWorx prior to 8.5, please check your settings for something that may have been missed.

 

Regards.

 

--Sharon

slangley
23-Emerald I
(To:slangley)

Hi @Mayur_Phase.

 

If one of the previous responses allowed you to find a solution, please mark the appropriate one as the Accepted Solution for the benefit of others on the community.

 

Regards.

 

--Sharon

slangley
23-Emerald I
(To:slangley)

Hi @Mayur_Phase.

 

Are you continuing to struggle to find a solution to your connectivity issue?  If so, please provide updated information so we can assist.

 

Regards.

 

--Sharon

Thank you.I was working on iot hub connector 8.5.  Yes Sure I will check again the connection setting as per your suggestion

 
Announcements