cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ES validation and publishing does not work anymore, who can help?

Newbie

ES validation and publishing does not work anymore, who can help?

validation error; Failed to authenticate experience server.

 

publishing error: localhost:3000 says: Uh-oh! Publish failed. Check the log for errors. Internal Server Error

 

log file:

 

[12/21/2017 15:14:57] Studio Version 8.1.2 (8.1.2.2343)

[12/21/2017 15:14:57] Status Message: Version 8.1.2 (8.1.2.2343)

[12/21/2017 15:14:57] Checking for updates from https://studio-download.vuforia.io/downloads/ThingworxMobileBuilderApp.application

[12/21/2017 15:14:58] Starting node.exe

[12/21/2017 15:14:59] debug: [twx-studio:studio-log] Debug logging enabled. DEBUG=twx-studio*

[12/21/2017 15:15:02] info: [twx-studio:initializer] Node version: 8.7.0

[12/21/2017 15:15:02] debug: [twx-studio:initializer] NODE_PATH C:\Users\adenkl2\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules

[12/21/2017 15:15:02] info: [twx-studio:initializer] ThingWorxStudio launched with the following arguments: _=[D:\syncplicity\adenkl2\Documents], help=false, version=false, $0=..\..\..\..\..\..\Roaming\ThingworxStudio\studio-download.vuforia.io\dist\server\index.js

[12/21/2017 15:15:02] info: [twx-studio:initializer] ThingWorxStudio dir:  C:\Users\adenkl2\Documents\ThingWorxStudio , home dir: C:\Users\adenkl2\Documents

[12/21/2017 15:15:02] debug: [twx-studio:initializer] Projects dir:  C:\Users\adenkl2\Documents\ThingWorxStudio\Projects

[12/21/2017 15:15:02] debug: [twx-studio:initializer] Extensions dir:  C:\Users\adenkl2\Documents\ThingWorxStudio\Extensions

[12/21/2017 15:15:02] debug: [twx-studio:initializer] ThingMarks dir:  C:\Users\adenkl2\Documents\ThingWorxStudio\ThingMarks

[12/21/2017 15:15:02] debug: [twx-studio:initializer] Move /VuforiaStudioEnterpriseExtensions

[12/21/2017 15:15:02] debug: [twx-studio:fileUtils] C:\Users\adenkl2\Documents\VuforiaStudioEnterpriseExtensions does not need to be moved, it does not exist

[12/21/2017 15:15:02] debug: [twx-studio:initializer] Move the projects dir

[12/21/2017 15:15:02] debug: [twx-studio:fileUtils] C:\Users\adenkl2\Documents\VuforiaStudioEnterpriseProjects does not need to be moved, it does not exist

[12/21/2017 15:15:02] debug: [twx-studio:initializer] Initialize builderSettings

[12/21/2017 15:15:02] debug: [twx-studio:index] Done with initialization

[12/21/2017 15:15:05] debug: [twx-studio:index] Startup process.argv is ["C:\\Users\\adenkl2\\AppData\\Local\\Apps\\2.0\\N3DHDX3E.WE4\\6PX8V3RD.A7N\\thin..udio_cd45769e4d993f77_0008.0001_30161406059f4db6\\node.exe","C:\\Users\\adenkl2\\AppData\\Roaming\\ThingworxStudio\\studio-download.vuforia.io\\dist\\server\\index.js","D:\\syncplicity\\adenkl2\\Documents"]

[12/21/2017 15:15:05] ar-extension version 8.1.2 (1.20.798)

[12/21/2017 15:15:06] debug: [twx-studio:extension-manager] extensionName to require ves-ar-extension

[12/21/2017 15:15:06] debug: [twx-studio:extension-manager] extensionName to require ves-basic-web-widgets-extension

[12/21/2017 15:15:06] debug: [twx-studio:extension-manager] extensionName to require ves-sample-projects

[12/21/2017 15:15:06] debug: [twx-studio:extension-manager] extensionName to require twx-data-provider

[12/21/2017 15:15:06] debug: [twx-studio:projectHelper] []

[12/21/2017 15:15:06] info: [twx-studio:index] Studio Ready: listening on 127.0.0.1:3000

[12/21/2017 15:15:06] debug: [twx-studio:importProject] StudioSample3DImport was already imported, however it must have been deleted because it no longer exists in the projects dir.

[12/21/2017 15:15:06] debug: [twx-studio:importProject] StudioSampleEyewear was already imported, however it must have been deleted because it no longer exists in the projects dir.

[12/21/2017 15:15:06] debug: [twx-studio:importProject] StudioSampleQuadcopter was already imported, however it must have been deleted because it no longer exists in the projects dir.

[12/21/2017 15:15:06] debug: [twx-studio:importProject] StudioSampleSpatial was already imported, however it must have been deleted because it no longer exists in the projects dir.

[12/21/2017 15:15:06] debug: [twx-studio:importProject] Done copying sample projects

[12/21/2017 15:15:15]  [0mGET /home  [32m200  [0m5.854 ms - 2825 [0m

[12/21/2017 15:15:17] debug: [twx-studio:sockets] a user connected  7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:15:18]  [0mGET /%7B%7B::projectType.imgPath%7D%7D  [32m200  [0m4.430 ms - 2825 [0m

[12/21/2017 15:15:18]  [0mGET /%7B%7B::view.imgPath%7D%7D  [32m200  [0m5.390 ms - 2825 [0m

[12/21/2017 15:15:18]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [32m200  [0m4.379 ms - 2825 [0m

[12/21/2017 15:15:18]  [0mGET /%7B%7B$root.currentProject.thingServerQRCode%7D%7D  [32m200  [0m5.322 ms - 2825 [0m

[12/21/2017 15:15:18]  [0mGET /images/%7B%7B::w.name%7D%7D.png  [32m200  [0m3.217 ms - 2825 [0m

[12/21/2017 15:15:18] debug: [twx-studio:sockets] EMIT builderSettings all

[12/21/2017 15:15:18] debug: [twx-studio:projectSettings] Skipping appDir "node_modules", no appConfig.json found

[12/21/2017 15:15:18] debug: [twx-studio:projectSettings] Skipping appDir "node_modules", no appConfig.json found

[12/21/2017 15:15:18] debug: [twx-studio:sockets] EMIT updateProjects 7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:15:18] debug: [twx-studio:sockets] EMIT updateProjects 7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:15:48] debug: [twx-studio:auto_configure] dev_portal_url https://studio.thingworx.com/api/v1

[12/21/2017 15:16:10] error: [twx-studio:auto_configure] 500 'Unable to retrieve service details.' Error: connect ETIMEDOUT 54.175.48.119:443

[12/21/2017 15:16:10]     at Object._errnoException (util.js:1021:11)

[12/21/2017 15:16:10]     at _exceptionWithHostPort (util.js:1043:20)

[12/21/2017 15:16:10]     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14)

[12/21/2017 15:16:10]  [0mGET /api/autoConfigure  [31m500  [0m21281.378 ms - 58 [0m

[12/21/2017 15:16:10] error: [twx-studio:index] unhandledRejection Unable to retrieve service details.

[12/21/2017 15:16:16] debug: [twx-studio:auto_configure] dev_portal_url https://studio.thingworx.com/api/v1

[12/21/2017 15:16:37] error: [twx-studio:auto_configure] 500 'Unable to retrieve service details.' Error: connect ETIMEDOUT 54.175.48.119:443

[12/21/2017 15:16:37]     at Object._errnoException (util.js:1021:11)

[12/21/2017 15:16:37]     at _exceptionWithHostPort (util.js:1043:20)

[12/21/2017 15:16:37]     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14)

[12/21/2017 15:16:37]  [0mGET /api/autoConfigure  [31m500  [0m21009.469 ms - 58 [0m

[12/21/2017 15:16:37] error: [twx-studio:index] unhandledRejection Unable to retrieve service details.

[12/21/2017 15:16:50] debug: [twx-studio:studio-log] Debug logging enabled. DEBUG=twx-studio*

[12/21/2017 15:16:55] debug: [twx-studio:upgradeProject] upgradeIfNeeded ShaftTest

[12/21/2017 15:16:55] debug: [twx-studio:ar-extension:upgrade] No upgrade needed per version check:  8.1.2 (1.20.798) 8.1.2 (1.20.798)

[12/21/2017 15:16:55] debug: [twx-studio:upgradeProject] Project does not need an upgrade.

[12/21/2017 15:16:55] debug: [twx-studio:projectSettings] write project settings ShaftTest

[12/21/2017 15:16:56] debug: [twx-studio:auth] Switching from server {} to new server thingworxServer=https://0khxdry8.studio-trial.thingworx.io, sslValidate=true

[12/21/2017 15:16:56]  [0mGET /api/switch  [33m401  [0m40.873 ms - - [0m

[12/21/2017 15:16:56]  [0mGET /api/switch  [32m200  [0m0.384 ms - - [0m

[12/21/2017 15:16:56] debug: [twx-studio:sockets] EMIT getProjectDefinition 7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:17:05] debug: [twx-studio:projectSettings] Skipping appDir "node_modules", no appConfig.json found

[12/21/2017 15:17:05] debug: [twx-studio:sockets] EMIT updateProjects 7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:17:05]  [0mGET /%7B%7B::projectType.imgPath%7D%7D  [36m304  [0m0.457 ms - - [0m

[12/21/2017 15:17:05]  [0mGET /%7B%7B::view.imgPath%7D%7D  [36m304  [0m0.797 ms - - [0m

[12/21/2017 15:17:10] debug: [twx-studio:projectHelper] Exporting project "FZG-Test", files to export: [ { name: 'appConfig.json', type: 'file' },

[12/21/2017 15:17:10]   { name: 'src/', type: 'directory' },

[12/21/2017 15:17:10]   { name: 'upgrade*.log', type: 'glob' } ] ...

[12/21/2017 15:17:10] debug: [twx-studio:projectHelper] finished export, total size: +  660276

[12/21/2017 15:17:10]  [0mGET /api/project/FZG-Test/zip/  [32m200  [0m377.625 ms - 660276 [0m

[12/21/2017 15:17:43] debug: [twx-studio:projectHelper] Exporting project "ShaftTest", files to export: [ { name: 'appConfig.json', type: 'file' },

[12/21/2017 15:17:43]   { name: 'src/', type: 'directory' },

[12/21/2017 15:17:43]   { name: 'upgrade*.log', type: 'glob' } ] ...

[12/21/2017 15:17:43] debug: [twx-studio:projectHelper] finished export, total size: +  661470

[12/21/2017 15:17:43]  [0mGET /api/project/ShaftTest/zip/  [32m200  [0m275.239 ms - 661470 [0m

[12/21/2017 15:25:14] debug: [twx-studio:upgradeProject] upgradeIfNeeded FZG-Test

[12/21/2017 15:25:14] debug: [twx-studio:ar-extension:upgrade] No upgrade needed per version check:  8.1.2 (1.20.798) 8.1.2 (1.20.798)

[12/21/2017 15:25:14] debug: [twx-studio:upgradeProject] Project does not need an upgrade.

[12/21/2017 15:25:14] debug: [twx-studio:projectSettings] write project settings FZG-Test

[12/21/2017 15:25:15] debug: [twx-studio:auth] Updating cached sslValidate to false

[12/21/2017 15:25:15]  [0mGET /api/switch  [32m200  [0m2.312 ms - - [0m

[12/21/2017 15:25:15] debug: [twx-studio:sockets] EMIT getProjectDefinition 7zmqI5FuGsOwnR2zAAAA

[12/21/2017 15:25:18] debug: [twx-studio:projectSettings] write project settings FZG-Test

[12/21/2017 15:27:40]  [0mGET /api/switch  [32m200  [0m0.569 ms - - [0m

[12/21/2017 15:27:40] debug: [twx-studio:basic] Authenticate using: thingworxServer=https://0khxdry8.studio-trial.thingworx.io, sslValidate=false

[12/21/2017 15:28:01] debug: [twx-studio:basic] Failed to authenticate experience server https://0khxdry8.studio-trial.thingworx.io null Error: connect ETIMEDOUT 52.201.175.242:443

[12/21/2017 15:28:01]     at Object._errnoException (util.js:1021:11)

[12/21/2017 15:28:01]     at _exceptionWithHostPort (util.js:1043:20)

[12/21/2017 15:28:01]     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14)

[12/21/2017 15:28:01]  [0mGET /api/validate  [31m500  [0m21055.607 ms - 42 [0m

[12/21/2017 15:28:09]  [0mGET /api/switch  [32m200  [0m0.790 ms - - [0m

[12/21/2017 15:28:09] debug: [twx-studio:proxy] Proxying request using: thingworxServer=https://0khxdry8.studio-trial.thingworx.io, sslValidate=false

[12/21/2017 15:28:30] error: [twx-studio:proxy] Proxy error { Error: connect ETIMEDOUT 52.201.175.242:443

[12/21/2017 15:28:30]     at Object._errnoException (util.js:1021:11)

[12/21/2017 15:28:30]     at _exceptionWithHostPort (util.js:1043:20)

[12/21/2017 15:28:30]     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14)

[12/21/2017 15:28:30]   code: 'ETIMEDOUT',

[12/21/2017 15:28:30]   errno: 'ETIMEDOUT',

[12/21/2017 15:28:30]   syscall: 'connect',

[12/21/2017 15:28:30]   address: '52.201.175.242',

[12/21/2017 15:28:30]   port: 443 } null 200

[12/21/2017 15:28:30]  [0mGET /ExperienceService/content/projects/FZG-Test  [31m500  [0m21017.373 ms - - [0m

[12/21/2017 15:28:30] error: [twx-studio:proxy] twx server proxy error...

[12/21/2017 15:28:30] error: [twx-studio:proxy]  Error: connect ETIMEDOUT 52.201.175.242:443

[12/21/2017 15:28:30]     at Object._errnoException (util.js:1021:11)

[12/21/2017 15:28:30]     at _exceptionWithHostPort (util.js:1043:20)

[12/21/2017 15:28:30]     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1175:14)

[12/21/2017 15:28:51] debug: [twx-studio:sockets] user disconnected  7zmqI5FuGsOwnR2zAAAA

Tags (1)
1 REPLY 1

Re: ES validation and publishing does not work anymore, who can help?

Klaus Endelmann​: It seems your Trial period has expired or could be an issue with your network blocking ES URL. To check expiry, login to studio.thingworx.com​ and confirm your Trial access status.

-Durgesh