cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Using a model target crashes Vuforia View

Highlighted

Using a model target crashes Vuforia View

I am trying to use the Model Target widget in Vuforia Studio to use my 3D model (.pvz CAD file) to track physical objects in an Experience. I was able to use my 3D model file and set a detection position for the model target widget, but when I try to see the Experience in Vuforia View (either on an iPhone 8-iOS11 or a Surface Pro 4), the app crashes right after the model target outline image appears on the screen.

 

Any ideas why this might be happening? Thanks!

3 REPLIES 3
Highlighted

Re: Using a model target crashes Vuforia View

I recently had the exact same problem. The problem was with the original cad.

When I removed the sub assembly that was causing the problem it worked right away.  

So how did I figure out what cause the problem? I "simply" removed one sub assembly at a time checking if it would make it work. Luckily I found the bad sub assembly in my thrid try.

 

The sub assembly was inserted two times into the main assembly but only one was causing the problem. I figure that is wasn't the sub assembly itself causing the problem but maybe something with the placement in the main assembly. What I ended up doing after trying several thing was making a surface of the assembly and insert that instead. 

 

I hope that you have a small assembly or is as lucky as me finding whats causing the problem.

 

Re: Using a model target crashes Vuforia View

Hi jandersen,

 

Thanks for your input. Unfortunately I have quite a complex assembly with many sub-assemblies and too many parts, but I will give your suggestion a try and see if I get lucky with an early assembly removal.

 

One quick question: When you say you ended up "making a surface of the assembly and insert that instead," do you mean you created a surface of the problematic sub-assembly and inserted that into your CAD file, or do you mean you created a surface of the whole assembly and inserted that in Vuforia Studio to create the model target? If the latter, can different CAD files be used in the same studio project for the model target tracking and the experience itself?

 

Thanks!

Highlighted

Re: Using a model target crashes Vuforia View

Thats too bad. I hope you are able to find the problem anyway.

 

I made a surface of the problematic sub-assembly and inserted that into the CAD file.

Announcements
Join an
AR Working Group!

Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection