Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

More lost data, more crashes. The hits just keep coming.......

22-Sapphire I

More lost data, more crashes. The hits just keep coming.......

Lost a couple days work. Yay. Have had to reboot the system probably 15 tims or more in the last 1-1/2 days. It turns out Windburn handles family table very poorly, especially when trying to copy them in the workspace. I copied the family table assembly, carefully renaming the instances so there wasn't any issue. Then I deleted the entire family table. That worked, but then when I wanted to delete the instances from the workspace, the HAL 9000 system told me I had to delete the generic. The system failed to either delete the instances from the Workspace (best solution) or even break the link between the files. So, again, I'm having to go outside the system to back up the assembly to a network drive, delete the entire family table, then bring it into the workspace.

Excuse me, but would it be too much to ask to have the system we paid a TON of money for, actually work as advertised so I don't have to keep using a network drive to get the job done? SRSLY?????


One of the BIG issues that we learned about, which is undocumented, is that Windchill cannot handle any family tables that contain asterixs. It floored me that this essential, time saving tool was omitted from Windchill functionality. We've since had to go back through our thousands of family tables to make sure all of the asterixs were converted to values, and we have to constantly remind users that this convenient functionality cannot be used in Pro/E. If you're running into corrupted family table files on Windchill-Pro/E transfers, check the tables for asterixs.

Deleting instances is cumbersome, but this should work:

- Open the generic

- Open all the instances

- Return to the Generic, delete the family table

- Save the generic. You should see a message stating the instances are no longer table driven

- Save each of the instances that are currently in session

This process will make the instances stand-alone so they can be deleted.

Ok, I tried something COMPLETELY different. I was going to back up the family table generic assembly to a network drive, then rename the assembly on the network, open the assembly, delete the entire table, then save it, thus saving it to the Workspace without the instances.

I found a much better and easier way, again, going outside the POS system: Simply do a "Save a Copy" in Pro/E in the generic model. You now get this popup window that allows you to select any models you want to reuse or copy, I just reused everything. When it copies the file, it does not copy the instances, so there is no family table to delete. you save it and then it's a new file in the workspace. Done.

And so, the best way to work in Windburn is to.......avoid using it when possible.

Thanks guys, I'll have to look at that. I REALLY hat this software. I wish I had my Intralink that had none of these issues.....

I know this is just about a year old, we identified this same issue, little sad if you ask me that PTC makes Creo so dependant on windchill and makes Creo work so well with family tables but yet windchill cant deal with family tables properly.....

however we did find a solution, we have been working with a developer for a differerent issue and they provided us with a Library wizard tool that takes family table parts and strips the generics out and checks the generics into windchill. Best solution to the problem so far, is the developer's website, program we have been using is Control's pro studio. I would email them for a demo

Thanks for the info Graham, I'll look into it!

no problem, its a frustrating problem. so I figured I would mention a possible solution

Much appreciated! Again, why they would replace Intralink, which worked GREAT with this, is beyond me.....oh wait, profit margins, how silly of me to forget......

Never used intralink we have only just started on implumenting Creo in the last year so still learning lots myself.

Have learned PTC is a funny company.... seems like they come up with good idea's take it just far enough to get people to start buying the itea then abandon it and move to the next idea..... and rather then recognize that there are more then one way to skin a cat and that customers might actually want to product nice drawings say like autocad can do they ignore or look down there noise at anything anyone else came up with....

honestly with what I know now if it wasnt for Creo's automation abilities I wouldnt use this software if PTC gave it out for free.....

doesnt make a nice drawing doesnt play well with plotters, doesnt work well without windchill, doesnt have good support from PTC just try to get ahold of them for support, finding any info on how to use alot of functionality is just about impossible almost like its a big secrete and only they may know.... gah.

well theres my rant of the day lol.

I feel your pain. I've used it about 17-1/2 years now. PTC, and Pro/E were totally different back then. Once they started pushing that Windchill monstrosity, they became a whole different animal, and not for the better. While I still believe Pro/E's capabilities are pretty much second to none, the GUI's on creo are awful, and Windchill is a nightmare that has to be lived to be believed. Intralink was better in every way I can think of, and far more reliable. Ah well...