Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Windchill workspace issue


Windchill workspace issue


I've worked on a project in a specific workspace for some days. No problems for saving modifications.

Now when I open the workspace I find that all my work is lost. The workspace seems to be back in the original state when I started the study.

It seems that some people already have this problem with windchill, kind of cache corruption I guess

Is it a way to recover my parts and assembly or to investigate the cache files?

Many thanks.

Creo 2 M100

Windchill 10 M040


Accepted Solutions

Thanks Marco.

I've seen this tool.

I'll try to install it know if the IT department let me do it...

23-Emerald II

In 10+ years of working with Windchill, I have never had a corrupt workspace.

I know I am asking for one now, but it is Friday and I'm off to Boston next week!

Ben Loosli a écrit:

In 10+ years of working with Windchill, I have never had a corrupt workspace.

Hey Ben you don't push Windchill to the limits, hurry up!  haha

Well, maybe I'm doing something wrong but I don't know what.

As usual I often switch from a workspace to another in a might be wrong

But what I'm sure:

- I accessed to this workspace maybe 15 times during the study without any problem, shutting down the computer every night.

- I didn't have any error message about check in because I didn't checked in (well...yes, it's bad)

- I didn't tried to remove anything of that workspace. No export or any fancy thing.

I can only see that this morning my workspace looks like I've not worked during the last week.


I've tried the recovery utility without success. I can recover only a few files and nothing useful.

Anyway, I'll keep it close to me and share with my co-workers for any further use. Thanks

Thank you guys. I think I have to rebuild all that stuff but I wouldn't be so confident and check in a little more often

I have dealt with a fair number of workspace corruptions in our company and usually that also means that the workspace can't be accessed at all from Creo (fatal error or server unavailable or other error). I can't recall a time when a corrupt workspace reverted back to the original unchanged files (at least not the whole workspace).

I see that you weren't checking in your file changes, but were you at least uploading them to the server workspace?

This problem sounds more like what would happen if your local cache had been deleted and Creo was rebuilding it from scratch based on the server workspace contents. May need to take a look at the dates on some of the files and folders in your local cache location. You should see some dates corresponding to the last time that you worked on the files.

Thank you John.

It sounds plausible. As I said I didn't upload my work on the server side at all. I know it's bad. 😕

23-Emerald II

I have my system set so any save will also perform an upload. Cheap insurance to get everything to server storage.

5-Regular Member

you can find the cache files in the cache folder. you can find cache location in the place of server management window.

sometimes you may find that the version before some changes is better, without upload, you can find it ,

once uploaded, you can not come back to the previous version of design any more.


Similar with the different version cap.prt.35 before using windchill. you have all .34.33 ...before purge, you can come back to cap.prt.33 if you want.


Ok, now I may have an explanation:

A few days ago , I've used a common login with administration rights to change manually some status on a few prts.

To use that login I opened an windchill session on IE to be clear an not make any mistake under my common session.

I once had a message when I opened Creo again saying something like:

"The server side cache owner is 1. Continuing with the session 2 is not recommended"

( 1 is my common login, and 2 is the admin login)


A co-worker just had the same issue (And is also as green as hulk now ), that's how I had the screenshot.

So I think we now know what we have to do.

Thank-you again.

Hope it may help any body

Top Tags