cancel
Showing results for 
Search instead for 
Did you mean: 
Security Alert Log4j Security Vulnerability. Click here to know more.
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot delete lines from sketch

ILoveMadoka
5-Regular Member

Cannot delete lines from sketch

Creo Parametric 3.0

 

I have a "shape" inside of a sketch that also contains other shapes.

The shape in question has 6 different sides.

No matter which order I choose I can only delete 4 of the lines.

Two of the lines (the last two left) cannot be deleted.

One time its the upper left two corner lines, next time I try it's the bottom two in the lower right corner,

next time I try I'm left with the bottom most line and top most line.

IT IS NOT THE SAME LINES EVERY TIME.

 

When I get to the last two I get "Invalid Selection, try again"

I've tried the DEL key, RMB -> Delete NOTHING WORKS.

I am about ready to put my fist through my monitors!!

 

I'm pissed, this is BFS!!!

 

Please help!

 

17 REPLIES 17

Since this is not typical - and if rebooting doesn't fix this and it happens in more than one part, then


Close Creo and add "graphics win32_gdi" to the config.pro file and restart Creo.

 

This will help diagnose a case where the lines are being deleted but the graphics software is still showing them, which would cause then to be an "invalid selection"

 

If that doesn't help, then you should prepare a case with PTC.

ILoveMadoka
5-Regular Member
(To:dschenken)

I don't think that is it.

The lines ARE there. I can select them.

They just will not delete.

Is it possible there is a relation in the sketch or somewhere that needs to be deleted before the lines can be deleted?

ILoveMadoka
5-Regular Member
(To:GaryLinscheid)

If there is a relation, you get an onscreen error stating that a relation exists...

That was not the case.

It might help if you include a screenshot of what you talking about. Include the entire Creo screen so we can get a context of what mode you are working in. Or attach the model.

You could also "save" the sketch (it saves sketches as .sec files), open it independently. Once saved out, it's not connected to the original sketch but it may help you diagnose the problem. 

I missed this post...

I wish I had done that....

Can you share the data?

ILoveMadoka
5-Regular Member
(To:Mahesh_Sharma)

Unfortunately, I cannot.

 

Plus, if you can delete it, that still doesn't help me.. 😕

 

Are there any error messages displayed when trying to delete the lines?

Do you have any sketcher relations?

With no information and nothing to look at, it's all just guessing.

 

Is the sketch related to downstream features?

 

I wish I had taken a screen shot.

 

I think the message said "Invalid Selection."

It wasn't like you'd hit <DEL> and get an error,

the error displayed at the bottom of the window at the command line...

 

I deleted all the relations. I don't think it was that because

I could delete different lines using different selection order.

Imagine a sketch with 3 hexagon shapes and I needed to delete one of them.

 

It's like it would not let me delete all the lines of that one shape entirely.

You could delete any 4 of the 6 lines in any order you wanted but the

last two lines could not be deleted.

 

I had to start all over so I'm no longer in the middle of this but I have

encountered this before so I was looking for a solution.

 

I think a support case can help, if you can share your your screen. Even it will be possible if your data is confidential under ITAR/NDA.  

ILoveMadoka
5-Regular Member
(To:Mahesh_Sharma)

Who do you contact to even do that?

 

With our Solidworks, we have an email address and phone number for technical questions.

I've not seen anything like that for any of our PTC products...

If you are in active maintenance for PTC.

 

 

You can submit a case from Creo Interface using File > Help > Log a support case. 

https://www.ptc.com/en/support/csguide/Contact

Phone, email, web-based.

The joke is 1-800-4-pro-hel   (1-800-477-6435

Supposed to be 4-pro-help but sounds better 4-pro-hell

 

Of course it doesn't work anymore since it's not pro/e, it's creo so....

Thank you for the information...

 

 

Unfortunately, I was under a time crunch and had to find a quicker workaround.

I should have save a copy of the screwed up file for reference...

 

Even I'm facing same problem with creo parametric in sketch mode please tell me the solution if you got the answer.

I have seen these things before.  I assume that it's because Intent Manager can't resolve the sketch if that entity is gone.  I've had luck with deleting that entity's constraints first or the references that it is tied to so that it's more "free".  Sometimes I end up deleting things I want to keep so I can free up the problematic entity and then I put those constraints back.

 

Unfortunately, without a screenshot it's hard to be more specific.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Announcements