cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 5+ causing flashing windows when running mapkeys; Vote for fix long overdue

tbraxton
19-Tanzanite

Creo 5+ causing flashing windows when running mapkeys; Vote for fix long overdue

PTC has apparently made changes to the code for Windows 10 (compliance for MS standards?) that cause flashing windows to be visible when running mapkeys. The visible mapkeys config option has no effect on this, I have a product enhancement request posted, please vote for it to get it on the to do list for development. This config option only works on the original menu based UI items and not the new GUI so it is rendered ineffective starting with WF release.

 

PTC explanation for the newly flashing windows:

P-50( Creo 5.0) lets Windows 10 add the desktop window manager glow to the borders of its windows.  When Windows does that it changes the composition level of the window, which affects the timing etc. of things such as map and unmap.  What you are seeing in P-50(Creo 5.0) is surely the fact that Windows takes marginally longer now to show/hide a window.

 

Vote for the fix to be implemented here:

https://community.ptc.com/t5/Creo-Parametric-Ideas/Update-functionality-of-visible-mapkeys-config-op... 

3 REPLIES 3
tbraxton
19-Tanzanite
(To:tbraxton)

PTC has a fix planned for Creo 9

  • Reported to R&D as SPR 11201949
  • Corrected in Creo Parametric 9.0.0.0
GabiPetrea
4-Participant
(To:tbraxton)

Hello, thanks for the info on this matter.

This actually is kind of a bad news, a lot of companies are and will be stuck for a few years between Creo version 5 – 9 , so this means a sluggish experience when running mapkeys.

Well we can’t have it all… 😊

tbraxton
19-Tanzanite
(To:GabiPetrea)

If we can get enough support to put it in a maintenance build it might happen. A big customer with a lot of seats would help push this. I requested that it be corrected in a Creo 7 build but they are not on board with that. I was stunned that no one had filed an SPR for Creo 5 or 6 for this issue.

Announcements