cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Drawing display style changes when I open the file

TC_skidz
5-Regular Member

Drawing display style changes when I open the file

Whenever I open a drawing, the Datum Display Filter and Display Style options match whatever I have for that session. So if I have a drawing that I saved with no datums displayed and on the "no hidden" display style, but I open it in a session where I've turned on datum display and I have my view set to Shaded with Edges, the drawing will now match those settings. How can I make those settings save to the drawing itself, rather than matching my session?

 

I attached a part file and drawing, but this behavior happens for all drawings, not just this one.

2 REPLIES 2

Datum Display Filter settings are global for the whole Creo session, so you can't disable them by default just for drawings and leave on for other modules (like Part or Assembly). When it comes to displaying datums, you just need to remember to turn them off in the drawing or set them to be off by default for the whole Creo.

 

As for displaying drawing, you have defined drawing view display as "Follow Environment", so the geometry display style in the drawing will match any setting you currently have for the whole Creo session. You need to go view properties, select View Display category and change Display style from "Follow Environment" to some other setting. That way your view will retain specified display style.

Also, if you want to define a particular display style for any drawing view you create, go to File > Manage > Drawing Properties > Detail Options and set model_display_for_new_views to other value than follow_environment. That way any new view you create in that drawing will use display style you defined through that option. And if you want to keep this setting as default for all drawings, you need to edit your .dtl file and change the same option (model_display_for_new_views) there.

I would also add that you should put the model datums on layers.  Then, in the drawing, hide the layers and save the layer status.  This will keep all of the datums hidden.


There is always more to learn in Creo.
Announcements