cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mass Properties Not Updating in Drawing

b-nappi
4-Participant

Mass Properties Not Updating in Drawing

hello,

 

I know this has been discussed in several different posts and elsewhere online but I haven't been able to find a working solution.  I have several drawings where the mass is not updating.  I am using &PRO_MP_MASS[.2] to indicate the parts mass.  I have the mass_property_calculate set to automatic.  I have tried recalculating the mass properties with file > prepare > model properties > mass properties > calculate > generate report, then regenerating the part and the drawing.  The mass properties report gives the correct mass.  But the mass will not update on the drawing.  I've tried updating my format, ect and nothing has worked.  Am I missing something?  Is there a better way to call mass properties to a drawing? 

 

I have been able to get the mass to update on some parts/drawings but not others.  

 

thanks 

1 ACCEPTED SOLUTION

Accepted Solutions
b-nappi
4-Participant
(To:b-nappi)

All,

 

Thanks for the responses.  I had been doing all the suggestions.  The mass properties were in a table in the format, not a note.  I was saving the generated mass properties report, ect.  

 

I finally figured out the problem (between the keyboard and the chair).  For this particular / unusual instance, the drawing was set up using a simp rep that doesn't display the whole part.  The mass didn't make sense and wouldn't change because it was being calculated from the whole part, not the simp rep.  Thanks to all who responded!

View solution in original post

5 REPLIES 5


@b-nappi wrote:

hello,

 

I know this has been discussed in several different posts and elsewhere online but I haven't been able to find a working solution.  I have several drawings where the mass is not updating.  I am using &PRO_MP_MASS[.2] to indicate the parts mass.  I have the mass_property_calculate set to automatic.  I have tried recalculating the mass properties with file > prepare > model properties > mass properties > calculate > generate report, then regenerating the part and the drawing.  The mass properties report gives the correct mass.  But the mass will not update on the drawing.  I've tried updating my format, ect and nothing has worked.  Am I missing something?  Is there a better way to call mass properties to a drawing? 

 

I have been able to get the mass to update on some parts/drawings but not others.  

 

thanks 


Hi,

test your problem on simple model. In case that &PRO_MP_MASS[.2] does not work >>> upload test files.

In case that &PRO_MP_MASS[.2] does work >>> upload problematic drawing+model (problem is specific for it).

Note: I hope that &PRO_MP_MASS[.2] is located in table cell in your format file.


Martin Hanák

After

file > prepare > model properties > mass properties > calculate > generate report

are you using the save button?

If not do so

Ian C
Mahesh_Sharma
22-Sapphire I
(To:b-nappi)

@b-nappi 

Steps you mentioned should work for you but as it is not working... what is it displaying in drawing? It is displaying &PRO_MP_MASS or the initial value of mass which is not updating. In format file, did you add &PRO_MP_MASS in table cell, if it is as note only, it will not work as expected. 

b-nappi
4-Participant
(To:b-nappi)

All,

 

Thanks for the responses.  I had been doing all the suggestions.  The mass properties were in a table in the format, not a note.  I was saving the generated mass properties report, ect.  

 

I finally figured out the problem (between the keyboard and the chair).  For this particular / unusual instance, the drawing was set up using a simp rep that doesn't display the whole part.  The mass didn't make sense and wouldn't change because it was being calculated from the whole part, not the simp rep.  Thanks to all who responded!

Mahesh_Sharma
22-Sapphire I
(To:b-nappi)

@b-nappi 

 

For part it is a limitation, for Assembly simp reps config option is available. You may mark your reply as correct answer for the post. 

Announcements