Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Two table questions


Two table questions

Hi all,

I built a 2-column table like so:

<usetext<br/>source='!<figtable frame="all" colsep="1" rowsep="0"><tgroup cols="2">
<colspec colname="col1" colwidth="8.5pi"></colspec>
<colspec colname="col2" colwidth="5pi"></colspec>
<row rowsep="1">
<entry align="center">PART<brk></brk>NUMBER</entry>
<entry align="center">FIGURE<brk></brk>&<brk></brk>INDEX NO.</entry>
</tgroup></figtable>!' placemnt="after">

There's too much space between each row, and I don't know where it's coming from. Is there any way to get rid of this extra space? I tried playing with leading on entry, row, the partno and figindex eics and the usetext but no luck.

My second question, is there any way to test for a column break? This table is on a 3 column page and I have to put an extra blank line after every ten rows, but the top of each column has to start over with ten rows again. So if I could reset the row counter on column breaks, I think that would solve the problem.


Hi Caroline,

In answer to your first question, It's hard to tell why you're getting extra space between rows unless you can show me how you are building up the variable. Any chance you can show what's being appended to this ?


Hi Caroline,
Extra space between table rows can be a combination of 2 things. First, the table cell padding is generally defaulted to 5 pts. You may want to adjust that. There is also a preferences setting that is tableminimumrowheight and I believe the default there is 15 points. I always adjust this one first and make it closer to 8 pts. Then, if it's still to spacey you can adjust the cell padding.


A good way to figure out the markup you need to accomplish what Trudy has
suggested is to play with "normal" tables in Editor. You can control a
table there through Table > Table Properties and then review the processing
instructions Editor has added by selecting the entire table and Edit > Edit
Selection as XML Source.


Andy, here is my code. Partno and figindex are inline:

<savetext textid="partno.txt" conrule="!&lt;entry">!,#CONTENT,!</entry>!"/>
<savetext textid="figindex.txt" conrule="!&lt;entry">!,@8pt,#CONTENT,!</entry>!"/>
<savetext textid="row.txt" conrule="partno.txt,figindex.txt"/">
<savetext textid="" conrule="!&lt;row">!,row.txt,!</row>!" placemnt="after" append="1"/>

Trudy, thank you for the tip. I changed the minimum row height but there was no difference.

Paul, I thought for sure that would work. Changing the padding to 0pt gave me this in the SGML:

I changed my figtable to a table and added 'cbmarg="0.00pt" ctmarg="0.00pt" to the tgroup but that didn't work. Then I added it to tbody, row, and table but still no change.

My guess is that the minimumtablerowheight needs to be added to the PE server. I'll let Clay or Paul tell you the best way to do that. If you aren't publishing locally, changing it only in your preferences won't make the change on the server. I still think that's where the problem is.

If tableminimumrowheight needs to be set on the PE server then what I would
do is this. Create an ACL file named "set_tableminimumrowheight.acl"
containing the following:

# Set tableminimumrowheight
set tableminimumrowheight=8pt

Then, I'd store it in PE's custom folder in editinit or init whichever is
the correct location and since I can't tell from reading the help, I'd
probably just put it in both locations. Trudy is right, the default is 15pt
according to help.

You will need to restart PE (Tomcat) for this to change processing if it is
the init folder that manages this setting. Reloading the subprocesses
should set it if editinit is correct.


thanks, guys, I am working locally. Trudy, how does one change the padding, if not by setting cbmarg="0.00pt" ctmarg="0.00pt" in tgroup?