cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

SOLVED

Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

Hi All, 

I am working on Creo 5.0.1.0 .

I have observed that the API  pfcSelection:: SetPoint()  is giving wrong results,

Can anyone explain this behavior??

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

Hi all,

Just a guess.  Could be missing UV parameters ( ProSelectionUVParamSet).

I would try the round-trip test - make a datum tag for a datum plane via UI, then write a code - select a tag, get attachments, get selection object, store all of this, delete the existing tag, create a new one with stored data and the tag should appear at the same location as the original one. If it is not happening - contact tech support

HIH. 

View solution in original post

4 REPLIES 4

Re: Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

what do you mean by wrong behavior?

 

What is the use case?

What were you expecting?

What was observed?

Re: Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

Thanks for the reply,

So here is the case,

I created the selection object as

pfcSelection_ptr selection = pfcCreateModelItemSelection(item); (Item which is surface)

then I set the desired center point to my selection object,

as selection->SetPoint(point);

then I created an Annotation (Set Datum Tag ) at this attachment(selection  object),

using ProMdlSetdatumtagCreate

But in UI the created SetDatumTag is attached to a different point of selection object,

 

 

 

Re: Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

Hi all,

Just a guess.  Could be missing UV parameters ( ProSelectionUVParamSet).

I would try the round-trip test - make a datum tag for a datum plane via UI, then write a code - select a tag, get attachments, get selection object, store all of this, delete the existing tag, create a new one with stored data and the tag should appear at the same location as the original one. If it is not happening - contact tech support

HIH. 

View solution in original post

Re: Creo ProToolkit API pfcSelection::SetPoint() is not working correctly.

Hi,

Thank you for the solution,

After setting The UV parameters in the selection object the Tag can be set at the Correct Location.

Announcements