Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - When posting, your subject should be specific and summarize your question. Here are some additional tips on asking a great question. X

Creo Sketcher 1.0 user problems


Creo Sketcher 1.0 user problems


I am a retired hobbyist with some programming background (when I was actively working). I am interested in playing around with the free Creo Sketch 1.0 2D program. The YouTube videos from PTC were nice and sparked my interest. I will probably never purchase anything, but I would surely like to see what Sketch 2D could do to allow me to create minor personal 2D drawings. I have investigated other free CAD programs, but Sketch sounds so interesting that I would like to try it. I downloaded the free .msi installer and ran it to install Sketch. It copied several new files and created a desktop icon that pointed to a sketch.bat batch file. I am running fully genuine Microsoft WIndows 7 Home Premium on a true Intel desktop computer with 4GB RAM and adequate hard disk space. I am the only user on this machine so I run as administrator.

I installed Creo Sketch 1.0 into the default C:\Program Files (x86)\PTC\Creo 1.0\ folder and the installer created several sub-folders and a desktop icon. All appeared normal until I attempted to run Sketch. All the double clicked desktop icon does is to open a batch file.

The sketch.bat file, when edited with Notepad++ shows that a path to certain folders to access certain DLLs should be created for the processor in my machine. Since Win 7 Home Premium won't allow me to run batch files, then the correct path does not get created. Instead, the only thing that happens when I double click the desktop icon for Sketcher 1.0 is that the batch file opens in Notepad++, but it won't run. I got into a command prompt window and changed directories while in that black window until I could see the sketch.exe file. When I attempt to run that I get a warning that the dll file named boost_regex_vc90-mt-p-1_45.dll is not present on my machine.I am not familiar enough with Windows to tinker with it too much, but I did try to copy all the DLLs from all the sub-folders containing the DLLs and put them into the C:\Windows\System32 folder. I know that is the repository for other DLLs used by other programs that I run occasionally. Still I get the warning when I attempt to run sketch.exe.

Now, after all that background info, comes the questions: What is the installer for Sketch doing wrong? What can I do within the normal bounds of Win 7 to cause Sketch to run? Any and all help you may offer will satisfy my desire for knowledge.

Thank you in advance

R Nelson

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.


I'd think Creo 1.0 runs on Windows 7 Pro or Ultimate. Doesn't matter if it's Creo Parametric or Creo Sketch.


24-Ruby II

From "Creo Sketch Data Sheet":


5-Regular Member

Hi Nelson,

Thanks for showing interest in Creo Sketch. The batch file (sketch.bat) sets up the path and environment variables that are needed for the sketch.exe to run. We follow this procedure so that we don't change the user path globally. Unfortunately this is creating a problem at your end. We will look into this. By the mean time, I'll suggest the following approach that you could try and let us know the result.

Set the following as user/system environment variables by going to "Computer->Properties->Advanced System Settings->Envirinment variables"


PROC_HOME=C:\Program Files (x86)\PTC\Creo 1.0\Sketch


In the user variable section edit the path variable, if exists already or create a new one as the following


Now open a command prompt and type path; You should see the fully expanded above directories in the path. Also check that the environment variable is available by

env | grep -i PAINT_HOME

Now go to the folder C:\Program Files (x86)\PTC\Creo 1.0\Sketch\bin\i486_nt\bin. Type sketch.exe. This should open up the Creo Sketch.

Please get back to us if you are still facing problems in startingsketch.exe. Also get back to us with your valuable feedback once it starts to run.



Dear Sankara

Unfortunately you lose. I have already tried fixing the path, but forgot to verify environment variable existance. I have already tried running with the suggestions from Kevin Bradberry, above, but found no success there either.

I have given up and uninstalled Creo Sketcher 1.0 and have moved on to other 3D products. Thank you for replying. I still think you may have issues that need fixing if you want users to try Creo Sketcher.

R Nelson

Top Tags