cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

Issue testing the Creo Parametric Toolkit Installation

ptc-4659621
1-Newbie

Issue testing the Creo Parametric Toolkit Installation

As a disclaimer I'm new to this and already not familiar with computers in this sense, so I could be missing something very basic.

 

I am getting an error when I try to build the make_install visual studio file. I think it is due to the environment variable PROE_INSTALL_PATH having an incorrect script but it looks correct to me.

 

I've set the variable path to C:\Program~Files\PTC\Creo~2.0\Parametric\, as it says to set to the parametric installation directory.

 

When I build make_install from MS Visual C++ 2010 Express I receive the following error:

 

1>------ Build started: Project: make_install, Configuration: Debug Win32 ------

1>

1> Microsoft (R) Program Maintenance Utility Version 10.00.30319.01

1> Copyright (C) Microsoft Corporation. All rights reserved.

1>

1>NMAKE : fatal error U1073: don't know how to make 'C:\PTC\Creo~2.0\Parametric\\protoolkit/protk_appls/pt_install_test/pt_install_src/TestInstall.c'

1> Stop.

1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command "nmake /f make_install dll" exited with code 2.

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

 

Why is the path using forward slashes after protoolkit? That part is automatically generated, so to me there is no way it can create a valid path..

 

I tried switching the variable path to: C:/Program~Files/PTC/Creo~2.0/Parametric/

 

but all that did was reverse the error to read: 'C:/PTC/Creo~2.0/Parametric//protoolkit\protk_appls\pt_install_test\pt_install_src\TestInstall.c'

 

What's the deal with this? Any help to get this working would be greatly appreciated.

 

Robert

4 REPLIES 4

I am having this exact same problem. Does anyone have a solution for this problem?

This may be a bit late, but I had this same problem and fixed it today. It turns out that my environment variable PROE_INSTALL_PATH was not set corrrectly.

It needs to be set to the installDir/Common Files\Mxxx folder using the DOS short name. My environment variable now looks like this: C:\PTC_Test\Creo2\COMMON~1\M070 - yours may be different.

Alternative Method:

Set the PROE_INSTALL_PATH to one folder above the protoolkit folder (usually the same as above). Still use the DOS short name. The compiler can then find the folders it needs.

FYI:

To find your DOS short name:

  • Open a cmd window
  • CD to the install Dir\Common Files\Mxxx folder
  • Type: for %I in (.) do echo %~sI
  • You will now see your DOS short name in the cmd window
  • Copy it into your environment variable PROE_INSTALL_PATH value

Hi,

this process is also is not working. I'm still getting the above mentioned error. 

Thanks

I know this might sound silly.

In Creo, Tools tab, Utilities, Open System Window, then type set

Does your PROE_INSTALL_PATH include the ~'s  like you have shown (C:\Program~Files\PTC\Creo~2.0\Parametric\)

or does it look contain spaces like this C:\Program Files\PTC\Creo 2.0\Parametric\

 

I haven't used MS Visual C++ 2010 Express so I am not familiar if it requires ~'s for spaces.

Top Tags