cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get called away in the middle of writing a post? Don't worry you can find your unfinished post later in the Drafts section of your profile page. X

Reconfigure Creo 2.0 (used to be bin/ptcsetup.exe)

davehaigh
11-Garnet

Reconfigure Creo 2.0 (used to be bin/ptcsetup.exe)

I finally found out from PTC why reconfigure wasn't working for me. (ptcsetup in ProE speak)

I had first installed Creo 2.0 in C:\ptc
I then installed it on a network drive I have mounted as P:

I could run reconfigure on the P: drive copy of Creo 2.0, but not on the C: drive copy.

I was pretty sure Creo was storing the location of the software somewhere. But couldn't find it.

Turns out they are storing it in the registry.

If the path that is stored in the registry doesn't match the path where you tried to run reconfigure from, reconfigure will not work.
The paths hi-lited below have to match. GRRRRRRR!

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PTC\Creo Parametric\2.0\2012060]
"DisplayName"="Creo Parametric"
"Release"="2.0"
"Datecode"="2012060"
"InstallLocation"="C:\\ptc\\Creo 2.0\\Parametric"
"InstallDir"="C:\\ptc\\Creo 2.0\\Parametric"
"InstallSource"="E:\\Creo Parametric 2.0\\F000"
"Shipcode"="F000"
"InstallTime"="4/13/2012"
"CommonFilesLocation"="C:\\ptc\\Creo 2.0\\Common Files\\F000"
"RegUse1To250"="true"
"QualityAgentOptIn"="1"

David Haigh
Phone: 925-424-3931
Fax: 925-423-7496
Lawrence Livermore National Lab
7000 East Ave, L-362
Livermore, CA 94550


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
3 REPLIES 3
TomU
23-Emerald IV
(To:davehaigh)

I discovered today that I couldn't reconfigure or uninstall Creo 2.0. Turns out this is a known issue (see

Tom U.

Title

Unable to uninstall Creo Parametric 2.0

Description

* Unable to uninstall Creo Parametric 2...


















Here's a script to do this: modify the path to match your environment.

attrib -R "%USERPROFILE%\AppData\Local\Temp\pimuninstall.exe"
del %USERPROFILE%\AppData\Local\Temp\pimuninstall.exe
attrib -R "C:\ptc\Creo 2.0\Parametric\bin\uninstall.exe"
appwiz.cpl

This last line bring up the add/remove programs wizard.

David Haigh
gspencer
4-Participant
(To:davehaigh)

Hello David,


I have something interesting, which falls right into this thread.


Setup - Installed Creo 2.0 onto my initial hardware. I went in to the registry and exports the Creo portion, as you noted in your PlanetPTC session. I zipped up the entire Creo 2.0 installation folder, for the purpose of copying to other machines.


Scenario - I have copied the Creo folder bundle to the exact same location as the original installation. Before I merged the .reg file, I launched Creo, and it lunched fine (some window about the start-in location, but ignored that for now). To see if the installation would reconfigure, I followed the process you laid out to be able to do a reconfigure/uninstal.


Note - I added the Help in afterwards on the new machine, which wrote to the registry, as normal. (this comes into play in a sec)


Issue - When I attempt to reconfigure Parametric, Simulation or Direct, the GUI comes up, but there are no "Applications to Customize", which makes me think that the regisrty entries aren't being recognized? However, it gets interesting in that when I attempt to reconfigure the Help (which was installed, rather than copied), I also get an empty list?


Any ideas? I would have at least expected the Help to be availavle, since I installed it the general way.


Any help is appreciated,


Gary


****Update- I was able to "reconfigure" my install, if I ran "setup.exe" from the original software bundle. Does this mean that "reconfigure" actually worked? - NO...looks like the setup.exe bypassed it, but at least I was able to update the existing configuration, which it found by looking at the registry entries I had merged back in. I am going to report this to PTC as I am very confident this a bug.