Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

pro/toolkit EXE application runs fine, but pro/toolkit DLL fails


pro/toolkit EXE application runs fine, but pro/toolkit DLL fails

I have creo 2.0 toolkit my exe apllication loads perfectly but when the same project is build as dll. Creo is unable to start the application. I have unlocked both the file and added appropriate line in the protk.dat i.e. for exe full path of exe and for dll full path of dll as well as the startupmode as DLL. but still it is failling to start. I have attached the snip of the messageboxI am getting.

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Hi Saurabh,

If you are building your app using MS Visual Studio, be sure that the .dll
is built in Release Mode and not Debug mode.

That gets me a lot...


Hi Ben,

Yes I am using MS Visual Studio 2010 for building the application.
I tried both debug and release dll and I got same error.



Each version of Pro/E requires a specific version of MS Visual Studio. Or
use the correct Microsoft libraries.
MS VS2010 - Creo 1.0 and 2.0
MS VS2008 - Wildfire 5.0
MS VS 2005 - Wildfire 4.0

Bob Monat
Jerand Technical Services, Inc.

hi jan,

Thanks. it was the .lib error, I did protoolkit.lib to protk_dll.lib now it
is working. your reply helped me.


Hi Jan,

Initially I was trying to build a managed C++ project for the Creo Object
Toolkit. It was giving me a compilation error of linking /md
(Multi-threaded DLL) with otk_cpp.lib and protoolkit.lib so I dropped that
idea. and started to build a C++ project with /mt (Multi-threaded) it
compiled but dll was not getting loaded. So when you suggested to use
protk_dll.lib in place of protoolkit.lib it started loading. In process of
that I find there are some lib file in pro/toolkit folder
like protk_dllmd.lib. so I included that into my initial managed C++
project and removed any dependency over Object Toolkit i.e. now my code is
pure pro/toolkit code. it is compiling without any error and getting unlock
as well but cero is not able to start application and showing the same
error which I was getting with my C++ dll.

so can you suggest me where I may be doing something wrong.


Hi Jan,

Can you assist me on the unlocking process of ProToolkit dll?
I have more then one project on toolkit but when I unlock one dll it holds
the instance for 15min so I was not able to unlock any other dll.
Is there a way to avoid this unlocking process at least for development
process? if not then is their a way free the instance before 15min so that
I can unlock other dll or a way to unlock more than one dll?


You can pass paths to multiple dlls at one time for unlocks.
I pass 4 dlls at one time, I am not sure if there is a limit and how many.

Also for Development purpose you don't need to unlock everytime.
Check Additional License Configurations during installation. Edit the
license profile you are using and add Pro/Toolkit to the list.

You should have a separate setup to check if the final application dlls are
unlocked or not.