Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Mathcad Prime 4.0 installation problems


Mathcad Prime 4.0 installation problems

I have Mathcad Prime Express 3.1 installed on my computer, and I'm trying to download and install 4.0 - i.e. upgrading.

I have downloaded a file 'pim_installmgr_mathcad.exe' and try to run it. It opens up, the PTC Installation Assistant runs up to 100%, Windows pops up to ask me to allow this program to make changes, I say yes - and then nothing. Nothing more happens. It just stops.

I have Windows 10 Home 64-bit as my OS.

I have tried running it as Administrator - same non-resuslt.

Please help - I'm absolutely flummoxed.


First uninstall Express 3.1 version (and delete all Mathcad Prime folder in the following path: C:\Users\AppData\Local\PTC\) and then install 4.0 version.

23-Emerald III

This should work with no problem. I have an (almost) identical situation where it worked without problems. The difference is that My system runs Win10/64-bit Professional (instead of Home). I had (and still have) Express Prime 3.1 installed, and downloaded and installed Prime 4. No problem, it runs.

There's only one thing that I can think of should be checked:

Do you have the correct (latest) DotNet installed?


As far as I can see I do have the latest dotNet installed. I'll try to uninstall 3.1 and install 4.0 later when I get home - and then cross my fingers it works (can't study without Mathcad)

Okay, I tried uninstalling Prime 3.1, and I still get the same result. The installer just runs up and then nothing...

And now I have no Mathcad on my computer...

Good day Nanna -
I see that you marked Vladimir Nosov‌'s answer correct, but from your last addition, it seems you are still having an issue.

Would you please confirm if your problem is resolved?

Thank you,


Hi Toby,

Yes, I'm still having problems. I thought it worked and thus marked it 'solved' only to find out my action was premature.



Hi Nanna.

I have the same problem, just like you. Do you have a tip? Please let me know.


Thank you


Please send your issue to PTC's tech support by using "Mathcad Support Center" (you can do it, even if you use Express version of  Mathcad Prime):

Mathcad Support Center


I have the exact same problem (except it is a brand new installation of Mathcad on a brand new computer). Worse : a colleague has exactly the same computer, with the same operating system (Windows 10), purchased the same day from the same shop, and the installation went well for him.


And, because things only get worse as time goes by, I can't contact PTC support because, as Mathcad Express user, I can't create an account to access support (because I don't have a customer number). I tried to call, but was just told off (again, because I don't have a customer number). All I can do is use an old PTC community login from 2 jobs ago to come and scream my frustration here...


It looks very much like PTC doesn't care about getting new customers. How am I going to have the employees of my newly created company try Mathcad and see if I want to get licenses ? Why would I even buy licenses if I can't install the software, and the support is non-existent ? And if I loose customers who want me to use Mathcad Express, I am certainly not buying licenses in the future, even if the problem gets fixed !


If anyone has any idea of either a way to fix the problem or to get in touch with PTC support (again, without a customer number), it would be very helpful...


I had the same issue. I have contacted the technical support and they made me download the zip file of the software (1Go) : available at → download software

Running the setup after the extraction worked perfectly.


Hello friend, currently I have the same problems with install the mathcad prime 4.0. Please send me information if you get a solution for this problem.


Thanks a lot




JMEN's solution worked for me