cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mathcad Prime 7.0.0.0 Crash when editing text box/block with multiple colors/bolded font

SER4
7-Bedrock

Mathcad Prime 7.0.0.0 Crash when editing text box/block with multiple colors/bolded font

I believe the title says it.

At first I though it might be related to having a Plot nearby or the text box overlapping.

Then I thought it was related to multiple colors of text.

I haven't quite narrowed it down, just wanted to bring it up for developers...(lol--do they read this?)

I am using Express.  Maybe my file is just getting too big (although it is still smaller than 1 MB).

1 ACCEPTED SOLUTION

Accepted Solutions

Do you by chance have "Text cursor indicator" set to "On"? 

MSheykman_0-1655030103845.png

If yes - disable it.

View solution in original post

19 REPLIES 19
VladimirN
24-Ruby I
(To:SER4)

Could you please provide Mathcad Prime worksheet as an example?

jfait
3-Visitor
(To:VladimirN)

I think, if you really want to replicate the MathCad crash, follow next lines:

  • add text field with "CTRL+SHIFT+T".
  • Write some text and change something. For example make the first letter bold "CTRL+B"
  • than if move with cursor with right arrow on keybard

-> boom all your work up to last save will be lost. It is really nightmare. Please fix this quickly. 

MSheykman
10-Marble
(To:jfait)

I was not able to reproduce the problem in Mathcad Prime 8 and 7 using these steps. 

There might be some additional circumstances that we are missing.

If you continue having this problem please turn to tech support.

Thanks - 

 

If that is the case, there must be something unique about my (and a few other's) installation - maybe some DLL or keyboard driver issue?  I'll open a ticket. . . .

VladimirN
24-Ruby I
(To:jfait)

I repeated these steps - there were no problems in version 7.0.

SER4
7-Bedrock
(To:VladimirN)

I just opened a new session of 7.0.0.0; blank document; followed @jfait steps exactly, and it crashed exactly as indicated/expected.

Reminder that I am on Express version (not the full paid version).  I wonder what you guys all have? And whether that might be relevant.

JW_9613894
3-Visitor
(To:SER4)

My guess is that is somehow a driver-related issue.  I am on a fully paid single-seat license - same behavior in Mathcad Prime 7 and 8.  Problem is the same with multithreading on or off and the same when I swap physical keyboards.  Using U.S. English keyboard setting in Windows.  It even happens using the Windows on-screen keyboard.

 

I just opened a support ticket a couple of hours ago.  waiting on a reply.

Do you by chance have "Text cursor indicator" set to "On"? 

MSheykman_0-1655030103845.png

If yes - disable it.

LucMeekes
23-Emerald II
(To:MSheykman)

Switching that feature on will cause Prime 2 to 8 to crash in the given scenario for me.

 

Success!
Luc

This issue affects all applications that use WPF rich text boxes. We reported this issue some time ago to Microsoft and they are fixing it. For more information see:

June 2, 2022-KB5013887 Cumulative Update Preview for .NET Framework 3.5 and 4.8 for Windows 10, vers...

Article - CS345407 - Mathcad Prime crashes on editing text within a specific worksheet when the OS f...

Thanks for providing this information.

According to the link you provided the PTC article you referred to seems only be available in Japanese and Chinese ?

Werner_E_0-1655035742474.png

 

This article is available in English, but I think you need to be logged it to ptc support site to see it. 


@MSheykman wrote:

This article is available in English, but I think you need to be logged it to ptc support site to see it. 


Actually I am logged in.

You are logged in automatically at PTC support when you log in on this forum and if I would not be logged in I would not be able to access the knowledgebase at all (not even in Japanese or Chinese).  Also my privileges should allow me to access the articles.
I followed the Japanese link and saw by the pics that the article correctly addresses  the problem in question here. Have no idea why its not offered in other languages. On the Japanese site there is a dropdown which offers the page in English, but when I chose it I again get the "Article .. was not found" message.

LucMeekes
23-Emerald II
(To:Werner_E)

I get the same: Article not found.

 

Luc

Well, anyway there is no additional information compared to this thread. It suggests to disable the "Use text cursor indicator" setting.

Thank you soooooooo much.  This has been horribly time-consuming problem and lost a lot of work because of it.   The text cursor indicator was definitely the problem.  No issues since implementing your fix  . . .

Screenshot 2022-06-12 101242.jpg

Thanks Again . . .

JW_9613894
3-Visitor
(To:SER4)

I have noted this same problem all too many times and shifted back to Mathcad 15 because of it.  However, I'd like to move forward with Prime.  I thought it would be fixed with Prime 8.0, but no luck - just lost a bunch of edits because of it.  Hard to believe this has not been fixed yet.

****************************************************************************************

PTC QA team - this is a REAL problem likely to lose customers

****************************************************************************************

I've tried a few methods of exiting a text box after changing formatting, and the only one that seems to work is clicking outside the text box area without touching the arrow keys.  Not sure how repeatable this method will be, but I definitely can reproduce the crash by formatting, then exiting the box with arrow keys.  Has anyone heard of a fix or other resolution?   After the many times I've installed the "latest edition" of Prime, it is STILL not reliable. I guess I'm going back to Mathcad 15 again . . .

LucMeekes
23-Emerald II
(To:JW_9613894)

No problem in Prime 7 or 8 for me.

 

I suspect that a Windows regional setting may be involved (knowing that certain keystrokes don't work for users with an Italian keyboard).

I'm on UK english language and using the US-International keyboard setting.

 

Success!
Luc

This has been resolved for me by turning off windows text cursor indicator in Windows settings. - Looking forward to start using Mathcad 8 Prime . . .

Announcements