cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Unable to import Thingworx Manufacturing app extension version 8.2.2

ahawaldar-2
6-Contributor

Unable to import Thingworx Manufacturing app extension version 8.2.2

Hi,

 

I am trying to import Thingworx Manufacturing app extension i.e. MED-61227-CD-082_SP2_ThingWorx-Manufacturing-Apps-8-2-2-extension-bundle into Thingworx composer. The version of thingworx composer is ThingWorx 8.0.9-b138. I am getting error as "Not Acceptable" when I click on import.

 

Please let me know what could be the issue.

 

Thanks,

Azim

6 REPLIES 6
hrajpal
13-Aquamarine
(To:ahawaldar-2)

Greetings Azim,

 

Please make sure you are having the same version of Manufacturing Apps and ThingWorx Composer to avoid such issues.

 

Thanks,

Himesh Rajpal

Hi @ahawaldar-2,

 

Manufacturing apps 8.2.2 version is not compatible with 8.0.9 ThingWorx Platform.

You need to import Manufacturing apps 8.2.2 on ThingWorx 8.2 platform version. These details are also mentioned in the ThingWorx Manufacturing Apps Setup and Configuration Guide

 

If my response has answered your question, please mark as Accepted Solution, for the benefit of others who may have the same question.

 

Thanks,

Himanshu

ahawaldar-2
6-Contributor
(To:hchanana)

Hello @hchanana,

 

Now I am importing ThingWorx-Manufacturing-Apps-8-2-2-extension-bundle into Thingworx platform which is of version  8.2.2. But the import is unsuccessful. The error what I am seeing is 

[L: ERROR] [O: E.c.t.w.ExtensionPackageUploader] [I: ] [U: Administrator] [S: ] [T: http-nio-8080-exec-3] [context: Extension Exception][message: Extension must have a metadata.xml file.]

 

Can you please let me know what could be the issue?

 

Thanks,

Azim

Hello @hchanana@hrajpal,

 

OK, now here is the new update from my end. I was doing it wrongly while importing ThingWorx-Manufacturing-Apps-8-2-2-extension-bundle. I need to import separately, first ThingWorx-Manufacturing-Apps-8.2.2-00-extension-dependencies and then ThingWorx-Manufacturing-Apps-8.2.2-00-extension. While I was able to successfully import ThingWorx-Manufacturing-Apps-8.2.2-00-extension-dependencies but facing new issue while importing ThingWorx-Manufacturing-Apps-8.2.2-00-extension. This time I am getting error as below.

 

2018-05-13 21:08:54.894+0530 [L: WARN] [O: c.t.n.Menu] [I: ] [U: SuperUser] [S: ] [T: http-nio-8080-exec-7] Submenu PTC.SCA.SCO.ConsoleSubMenu in PTC.SCA.SCO.ConsoleMenu does not exist
2018-05-13 21:09:02.069+0530 [L: ERROR] [O: c.t.c.ImportProcessor] [I: ] [U: SuperUser] [S: ] [T: http-nio-8080-exec-7] Unable to process import: java.lang.NullPointerException
2018-05-13 21:09:02.080+0530 [L: ERROR] [O: c.t.e.u.ExtensionPackageUtilities] [I: ] [U: SuperUser] [S: ] [T: http-nio-8080-exec-7] Unable to delete SCO_Common-extension:8.2.2. This is likely due to other errors: ExtensionPackage SCO_Common-extension Does Not Exist

Hi @ahawaldar-2,

 

This error usually occurs if the compatible software are not installed on your machine or due to Improper procedure used during import.

 

Please refer the article https://www.ptc.com/en/support/article?n=CS269814 and validate the steps mentioned in the resolution.

 

Also make sure you have proper license installed for using manufacturing apps.

 

Thanks,

Himanshu

slangley
23-Emerald II
(To:hchanana)

Hi @ahawaldar-2.

 

If the solution previously provided by Himanshu was successful in resolving your issue, please mark it as Accepted Solution, for the benefit of others who may have the same question.

 

Regards.

 

--Sharon

Top Tags