cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with Creo Parametric assemblies.

SOLVED
Level 1

Issues with Creo Parametric assemblies.

Attached are two images of a student trying to assemble parts for a can crusher using Creo Parametric. When the student attempts to constrain the parts we get the second image. We are not sure what is happening and it makes it very difficult to assemble parts. This happens on the majority of our PCs although not the newer ones. Could it just be a graphics issue? Has anybody experienced a similar problem? I have attached a word file with more of the same. Our school uses Windows 7.

Creo+issue+1.pngCreo+issue+2.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Issues with Creo Parametric assemblies.

I have recently stumbled across addional info regarding the graphics display options in Creo 2.0. According to development, customers having graphics problems should try the following options, in order (i.e., if option 1 does not work, try option 2, option 3 and then option 4 as the last resort):

  1. Update your graphics drive to the latest available. This is always the best option.
  2. Try adding both of the options below. Using both options together will utilize all OpenGL performance improvements made in Creo.
    • graphics opengl
    • use_software_opengl yes
  3. Use only the "use_software_opengl yes" option.
  4. Use the "graphics win32_gdi" option.

Rather than edit the config.pro file at the install location (many uses do not have permission for this), Creo will also read a config.pro file placed in the "Start in" folder. For Windows 7, the default Start-in folder for Creo is (Users/Public/Documents).

Since I can't seem to attach a file to this comment, I've uploaded a zip file with a config.pro file that contains all three options listed above but they are commented out using an ! mark. You can place this file inside your Start-in folder and try the combinations above by simply removing the ! from the option you wish to try (must restart Creo after saving the config.pro file). I hope this helps.

Regards,

Adam

3 REPLIES 3

Re: Issues with Creo Parametric assemblies.

Try going to "File", "Options", "Configuration Editor", click "Add", type in "Graphics" and select "Win32_gdi".

I'm not sure if the graphics are looking funny because you are using component interfaces or not. You might try deselecting that option and assembling manually to see if there are any differences as well.

graphics.jpg

Re: Issues with Creo Parametric assemblies.

I have recently stumbled across addional info regarding the graphics display options in Creo 2.0. According to development, customers having graphics problems should try the following options, in order (i.e., if option 1 does not work, try option 2, option 3 and then option 4 as the last resort):

  1. Update your graphics drive to the latest available. This is always the best option.
  2. Try adding both of the options below. Using both options together will utilize all OpenGL performance improvements made in Creo.
    • graphics opengl
    • use_software_opengl yes
  3. Use only the "use_software_opengl yes" option.
  4. Use the "graphics win32_gdi" option.

Rather than edit the config.pro file at the install location (many uses do not have permission for this), Creo will also read a config.pro file placed in the "Start in" folder. For Windows 7, the default Start-in folder for Creo is (Users/Public/Documents).

Since I can't seem to attach a file to this comment, I've uploaded a zip file with a config.pro file that contains all three options listed above but they are commented out using an ! mark. You can place this file inside your Start-in folder and try the combinations above by simply removing the ! from the option you wish to try (must restart Creo after saving the config.pro file). I hope this helps.

Regards,

Adam

Re: Issues with Creo Parametric assemblies.

Our IT technicians updated all our graphics drivers and the issue has been solved. Thank you for your help.