Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Blank screen HELP!


Blank screen HELP!


Whenever I start a new 'part', I get a blank screen with which I cannot do anything. The Front, Top, and Right planes are not shown. thus I cannot start any project or work. Here's the picture ...


Any idea?

Any help is greatly appreciated.

For your information, I have a school's edition of Creo Parametric.




It appears that your datum display is disabled. This is changed in the Graphics Toolbar at the top of the graphics area.



Thanks for the reply. But I've already activated those displays, even checked the "Show Datum" option from the "Options" tool. Yet, graphics area remains to be blank.

Any more ieas?


When you select a datum in the model tree, does anything in the screen highlight?

Nothing happens, nothing comes on. Jus that blank white screen.

If it's any help, I'm running Creo Parametric 1.0 on Windows 7.

I would suggest you update your graphics drivers. Often even new computers ship with outdated graphics drivers. Although I have never seen this specific problem, it has been my experience that updating the graphics drivers will fix 99% of the graphics problems (and this is a graphics problem).

Worked perfectly! Thank you!

Updating my driver may have also fixed other graphical problem I've been experiencing.

Thanks again!

Great news!

Same problem, but I am running a Creo Parametric 2.0 version and windows 7 and I have installed the latest version of my graphic driver.

Hi Tom,

What type of graphics card to you have in your machine?

Can you do me a favor and navigate to:

C:\Program Files\PTC\Creo 2.0\Common Files\M010\text

Open in a Notepad.

Add the following line:

graphics win32_gdi

Save the file. Note: you might have to save to your desktop as writing to the C drive is not permitted. Then drag the file from the desktop to the text folder. Overwrite the existing file.

Start Creo 2.0. again.

This has changed the setting to use emulated graphics for Creo 2.0.



Thank you soo much it now works!

Many thanks,

Tom Xiong

Great news. Please keep checking for an updated driver. If you find one, remove the option you added to the file and see if the graphics card can manage the graphics. If not revert to using the option.



Worked for me tooo.

Thanks for the help