cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 7 ModelCheck material in modelupdate mode

kotlownia
7-Bedrock

Creo 7 ModelCheck material in modelupdate mode

With the addition of the default material PTC_SYSTEM_MTRL_PROPS in Creo 7, ModelCheck's material_info in ModelUpdate mode stopped working. Before Creo 7, it used to assign the material you chose in models that didn't have any materials. The new default material wouldn't be a problem, but it doesn't have any parameters (density being the most important) which breaks mass calculation for assemblies.

 

As written in CS326615, you can add density to this default material in your templates, but that doesn't help me when I'm updating old models. Does anyone have a suggestion on how to solve this problem? For now we were using Creo 6 to ModelCheck old assemblies before importing them to Windchill but I'd rather have everyone use Creo 7 only.

3 REPLIES 3

Hi,

 

Thanks for bringing this to our attention. You can apply a material from the material list supplied in the start file when you run ModelCHECK, but that takes place within the ModelCHECK report. But it does appear that ModelUPDATE does not work properly with this check in Creo 7.0. I'll look into getting a fix for this. I'd also encourage you to file a tech support case so that we can track it better.  But I also realize this doesn't help you in the short term, unless you're okay with the workaround of changing the material from within the ModelCHECK report. 

 

Luke

@kotlownia It's looking like we'll be able to fix this in an upcoming release. I'll provide more details when I have them. Thanks for bringing this to my attention.

llie
14-Alexandrite
(To:kotlownia)

We ran across a similar issue with ModelCheck not throwing a error when PTC_SYSTEM_MTRL_PROPS material is assigned to a model so we implemented the following into our ModelCheck files since PTC_SYSTEM_MTRL_PROPS has a density of 1.

In the checks.mch file add the following line:
PRT_DENSITY YNEW E E E E E

In the constant.mcn file add the followings (Yes that is two P's in the second line):

DENSITY LOW 0.000001

DESITY_UPP 0.9 

Since we just implemented it today, we are rewriting our code to the score will be a lot lower.

 

MC_ERROR.jpg

 

 

Announcements