cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Creo Parametric 2.0 Crashes when I open it.

ptc-5232180
1-Newbie

Creo Parametric 2.0 Crashes when I open it.

Hello, I have been trying to read on related issues but I cannot seem to fix my problem. I had Creo installed previously but my old license expired and I got a new student license. I first tried updating just the license but that was not working so completely deleted PTC creo from my computer and used the emailed link to re-install it. As soon as I try to run Creo parametric or any other OTC product it crashes givin me the following window:

Creo+Error.JPG

 

It also created a traceback.log file which says the following:

 

-------------------------------------------------

The trace creation timestamp is: Wed Oct 08 20:17:02 14

The executable build timestamp is: Fri May 23 14:55:18 14

The datecode is: NA

The pro machine type is: NA

The process ID is: NA

The traceback type is : CRASH

-------------------------------------------------

Exception EXCEPTION_ACCESS_VIOLATION has occurred in the thread 14124.

 

All of my drivers are up to date and the config.pro file only containts the following information:

 

drawing_setup_file $PRO_DIRECTORY\text\prodetail.dtl

format_setup_file $PRO_DIRECTORY\text\prodetail.dtl

pro_unit_length unit_inch

pro_unit_mass unit_pound

template_designasm $PRO_DIRECTORY\templates\inlbs_asm_design.asm

template_drawing $PRO_DIRECTORY\templates\c_drawing.drw

template_sheetmetalpart $PRO_DIRECTORY\templates\inlbs_part_sheetmetal.prt

template_solidpart $PRO_DIRECTORY\templates\inlbs_part_solid.prt

todays_date_note_format %Mmm-%dd-%yy

tolerance_standard ansi

weld_ui_standard ansi


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
6 REPLIES 6

I forgot to mention that I downloaded, intalled, and ran Creo successfully on my other PC but the one I mainly need it on keeps failing.

Erick,

it is difficult to give you some advice.

I guess that the current installation is corrupted. So I suggest you to remove it (i.e. uninstall and delete installation directory if it is not removed by uninstall procedure).

Note:

Replacing old license with the new one is easy. In Creo Parametric 2.0 you have to check/modify the contents of ...\Creo 2.0\Parametric\bin\parametric.psf file (ENV=PTC_D_LICENSE_FILE-=... and ENV=CREOPMA_FEATURE_NAME=...)

Martin Hanak


Martin Hanák

Martin,

Thank you for the feesback. I have tried what you suggested several times but it yields the same results. Is there a general Creo donload link? The only method I currently know of is to go through the link given by email. I Have also tried to use a lincense that came with a Creo book i bought but everything still crashes; are there any extra things that Creo intalls that I might be overlooking when I do a complete uninstall?

Erick,

I guess that the problem is caused by some software "knot" hidden inside Windows. Therefore I can't help you. Maybe clean Windows installation will resolved the problem ... maybe not ...

Martin Hanak


Martin Hanák

It is also worth removing the graphics driver issues by overwriting the OPENGL default with win32_gdi in config.pro. Is this new system PTC certified?

Hi

we had a similar problem where 4 out of a total of 120 laptops would accept the install but would crash on opening.

It turned out to be something to do with having an embedded graphics card in the laptop

I set this hidden config option and it cured it

enable_opengl_fbo no

If you enter this option in the PTC support page search box it will give you a bit more information

Top Tags