Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - When posting, your subject should be specific and summarize your question. Here are some additional tips on asking a great question. X

Creo2 installed, have a few questions


Creo2 installed, have a few questions


I just got Creo2 installed and have most things setup, but I have a few questions.

In my config I have (datum_point_tag_display yes) and it doesn't load the tags when I start up. I tried turning them on manually and saving out the config and restarting, still doesn't work. Anyone else see this issue?

I get a std.out
Allowing Crash: set_master_handler()

I get a std.err
pm_is_portmapper_port_busy: bind failed, error = 10013
pm_is_portmapper_port_busy: bind failed, error = 10013

Anyone know how to resolve these?

I'm not using a file, it doesn't seem to be applicable with all the changes, so I just didn't use it.

Thank you

Ryan Crisp | Senior Mechanical Engineer

Priority Designs
501 Morrison Rd.
Columbus, OH 43230
(614) 337-9979
This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
21-Topaz II
(To:rcrisp) is obsolete, Creo uses *.ui files that are loaded only from your user profile in Windows. I still haven't figured out what to do with that company wide.

Another issue is each software mode (part, assembly, drawing, etc) has different ribbons. So, changing the model tab in assembly mode will not make a change in part mode. Someone found 26 different 'modes' in Creo. Makes UI tweaking frustrating.

I get the same errors in my install every time. They don't seem to cause any issues, but we've just recently started more heavy use of Creo so I'd too be curious of a solution.

Doug Schaefer | Experienced Mechanical Design Engineer

As far as the .ui file goes, Look at

The message in the std.out file can be suppressed, but PTC doesn't recommend it. It indicates that Creo will create a traceback.log file when it crashes. You can turn it off with the config option auto_traceback never. See CS59617

I don't get the pm_is_portmapper errors. You should contact PTC about that.

David Haigh
5-Regular Member

Here is some information on the portmapper error:

Document - CS49331

Document Actions

* Refresh Data
* Subscribe to this Document

Document Information



Date Created

16-Feb-2012 12:45:42 EST

Date Last Updated

20-Mar-2013 17:48:14 EDT

Document Details


Std.err file reports "pm_is_portmapper_port_busy: bind failed, error =
10013" in Pro/Engineer Wildfire 5.0


* Std.err file reports following pm_is_portmapper_port_busy: bind
failed, error = 10013

Applies To

* Pro/ENGINEER Wildfire 5.0 all datecodes
* Creo Elements/Pro 5.0 all datecodes
* Creo Parametric 1.0 - 2.0 all datecodes



* Possible reasons for std.err file reporting error:

* Message usually brought up by service launched when
ptcportmap.bat (found in proe_loadpoint/bin) was executed on machine.

* ptcportmap.bat is a service used to link PTC
applications (either Pro/INTRALINK or any Pro/Toolkit tools)
* Old service, no longer in use

* TPI 104169
* TPI 118371
* Software EMC Legato NetWorker PortMapper installed

* Disable this software

* Related to ModelCHECK - TPI 114115
* Environment variable PRO_COMM_MSG_EXE not set correctly
* Multiple versions of Simlab software installed
* System issue

* Example, out-of-date or incompatible OS library causing
low level communications to be dropped by operating system

David Krumwiede
Pure Fishing

So first off, that message about 26 different modes isn't correct. You don't need to customize the ribbon in that many modes. Once for each of the major modes will do it. Part, Assy, Drawing, Sheet metal, & Simulate. It doesn't matter if you bring up a Part from an assembly or from the open file menu, the ribbon for part mode it the same. (All I'm doing is defining a new tab and putting our custom mapkeys in that tab.)

Secondly, what I decided to do was not place a .ui file in the loadpoint. It makes it difficult if I want to make changes to it.

My startup script copies the .ui file down to the users cache location, and the also sets load_ui_customization_run_dir to yes
This allows the user to have their own customizations in the run dir, while I put the standard in their cache location.

The advantage of this is I can create a special startup script that only uses the .ui in the run dir, so that I can modify our "standard" .ui.

I added these line to my startup script:

1. del "%USERPROFILE%\pro\Creo_2_home\cache\no_pdm_cache\PTC\ProENGINEER\.Settings\creo_parametric_customization.ui"

2. echo f|xcopy "P:\Creo 2.0\dted_configs\creo_parametric_customization.ui" "%USERPROFILE%\pro\Creo_2_home\creo_parametric_customization.ui" /y /r

3. set PTC_WF_ROOT=%USERPROFILE%\pro\creo_2_home\cache\no_pdm_cache\PTC\ProENGINEER

Line one deletes any .ui that would be in the cache.
Line two copies the "standard" .ui file to the run dir
Line three sets the cache location

If you go to File, Help, System Information, you will see that there is only one .ui file loaded.
Top Tags