cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Inertia measurment

BB_10451093
3-Visitor

Inertia measurment

I am using Creo Parametric Release 7.0 and Datecode7.0.9.0

When I use Analysis / Mass properties / preview
The coordinate system displayed at center of gravity with respect to principal moment of inertia axis (1, 2, 3) seems not correct. For example, if I extrude a cylinder whose axis is not colinear to origin cordinate frame, the principal moment of inertia displayed is not colinear to the cylinder (when it should be)

6 REPLIES 6

I'm using Creo 9.

Built a cylinder, 1.50 diameter, extruded from Z=0.00 to Z=3.00, centered on X=-2.00, Y=0.00.

Mass Analysis preview shows:

VOLUME =  5.3014376e+00  INCH^3
SURFACE AREA =  1.7671459e+01  INCH^2
DENSITY =  9.9000000e-02 POUND / INCH^3
MASS =  5.2484232e-01 POUND 
CENTER OF GRAVITY with respect to CS0 coordinate frame:
X   Y   Z    -2.0000000e+00  0.0000000e+00  1.5000000e+00  INCH

INERTIA with respect to CS0 coordinate frame:  (POUND * INCH^2)

INERTIA TENSOR:
Ixx Ixy Ixz  1.6483330e+00  0.0000000e+00  1.5745270e+00
Iyx Iyy Iyz  0.0000000e+00  3.7477021e+00  0.0000000e+00
Izx Izy Izz  1.5745270e+00  0.0000000e+00  2.2469812e+00

INERTIA at CENTER OF GRAVITY with respect to CS0 coordinate frame:  (POUND * INCH^2)

INERTIA TENSOR:
Ixx Ixy Ixz  4.6743777e-01  0.0000000e+00  0.0000000e+00
Iyx Iyy Iyz  0.0000000e+00  4.6743762e-01  0.0000000e+00
Izx Izy Izz  0.0000000e+00  0.0000000e+00  1.4761190e-01

PRINCIPAL MOMENTS OF INERTIA:  (POUND * INCH^2)
I1  I2  I3   1.4761190e-01  4.6743744e-01  4.6743795e-01

ROTATION MATRIX from CS0 orientation to PRINCIPAL AXES:
       0.00000        1.00000        0.00000
       0.00000        0.00000        1.00000
       1.00000        0.00000        0.00000

ROTATION ANGLES from CS0 orientation to PRINCIPAL AXES (degrees):
angles about x  y  z -90.000          0.000        -90.000 

RADII OF GYRATION with respect to PRINCIPAL AXES:
R1  R2  R3 5.3033009e-01  9.4372905e-01  9.4372956e-01  INCH

1-2-3 temp coordinate system at center of gravity is exactly where I'd expect it.

 

 

Hi,

Thank's for your answer,

I made the same cylinder as you did. I have exactly the same mass analysis (different units 😉).
But the axis displayed seems to correspond to nothing, see attached picture. In my opinion, the axis I1 should be colinear to the axis of the cylinder (parallele to z axis).

What do I miss ?!

 

Capture.PNG

 

VOLUME = 5.3014376e+00 MM^3
SURFACE AREA = 1.7671459e+01 MM^2
DENSITY = 1.0000000e-06 KILOGRAM / MM^3
MASS = 5.3014376e-06 KILOGRAM
CENTER OF GRAVITY with respect to _PRT0001 coordinate frame:
X Y Z -2.0000000e+00 0.0000000e+00 1.5000000e+00 MM

INERTIA with respect to _PRT0001 coordinate frame: (KILOGRAM * MM^2)

INERTIA TENSOR:
Ixx Ixy Ixz 1.6649828e-05 0.0000000e+00 1.5904313e-05
Iyx Iyy Iyz 0.0000000e+00 3.7855577e-05 0.0000000e+00
Izx Izy Izz 1.5904313e-05 0.0000000e+00 2.2696780e-05

INERTIA at CENTER OF GRAVITY with respect to _PRT0001 coordinate frame: (KILOGRAM * MM^2)

INERTIA TENSOR:
Ixx Ixy Ixz 4.7215937e-06 0.0000000e+00 0.0000000e+00
Iyx Iyy Iyz 0.0000000e+00 4.7215921e-06 0.0000000e+00
Izx Izy Izz 0.0000000e+00 0.0000000e+00 1.4910293e-06

PRINCIPAL MOMENTS OF INERTIA: (KILOGRAM * MM^2)
I1 I2 I3 1.4910293e-06 4.7215903e-06 4.7215954e-06

ROTATION MATRIX from _PRT0001 orientation to PRINCIPAL AXES:
0.00000 1.00000 0.00000
0.00000 0.00000 1.00000
1.00000 0.00000 0.00000

ROTATION ANGLES from _PRT0001 orientation to PRINCIPAL AXES (degrees):
angles about x y z -90.000 0.000 -90.000

RADII OF GYRATION with respect to PRINCIPAL AXES:
R1 R2 R3 5.3033009e-01 9.4372905e-01 9.4372956e-01 MM

 

Hi,

please pack your part into zip file and upload zip file.


Martin Hanák

 

Hi,

in Creo 7.0.5.0 I can see this "picture".

MartinHanak_0-1665563317756.png

 

1.] maybe your Creo 7.0.2.0 contains a bug (try installing 7.0.5.0 to verify it)

2.] maybe your config.pro contains some specific option causing the problem (please upload config.pro)

 


Martin Hanák

Hi @BB_10451093,

 

I tested the part in Creo 7.0.2.0 and 7.0.9.0, already tested by Martin in Creo 7.0.5.0, seems it was a bug in Creo 7.0.2.0 as it is reproducible for me  in Creo 7.0.2.0 but not in other datecodes. 

 

Check the image from two of the datecodes 

 

 

I hope this will help. 

 

Thanks. 

Top Tags