cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Highlighted
Aquamarine

Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

I'm wondering how companies are keeping Instance Accelerator's up to date.  There are two ways to update them. Which method are you using?

1) User manually go into the file menu (File -> Manage File -> Instance Accelerator -> Update Accelerator)  Or a mapkey to do this.

2) Set the config setting "update_accelerator_in_verify yes".  This updates the accelerator upon verify of the family table.

Or I guess another way to state this..why would I not use the config setting if instance accelerators are being created?

7 REPLIES 7
Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Bill Ryan, we do not currently use, create, or save instance accelerator files (to Windchill.)  We had some issues in the past where the accelerator file was out of date and causing issues in Creo.  Digging through the knowledge base, it looks like PTC has made some strides recently in making sure they are kept up to date (new config options, etc.)

I guess one question I would have is, if our family tables are small and relatively simple, is the benefit of using an accelerator file really worth the overhead (creation, update, storage in Windchill)?

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Tom,

We have 11 buildings of Creo across the world with 5 different admins managing the Configs.  Since PTC has made the setting for creating Instance Accelerators as default OOTB...we had one Admin that didn't specifically set it to no.  So we have about 18 months of engineers creating them...the good news is that we haven't had any issues with them.  We have out of date IA's which is why I'm asking the question.  This is was another issue...I haven't figured out how to make them out of date.  They have built some intelligence into the IA that I haven't reverse engineered yet!  It really bothers me that I was seeing the last modified on the IA attachment not matching up with the last modified of the Creo file.  Having the additional config setting above should eliminate that and almost all issues with out of date IA's.  

If you are curious about the purpose of Instance Accelerators I would recommend creating a data set with and without them on a similar assembly.  The picture I have below represents one of our large assemblies that I use for baseline testing...(it doesn't have IA's tied to it).  The geoemetry is the same for all three cases below...the left two represent an assembly with family tables...while the far right test is the same assembly where I converted every family table instance to a stand alone object.  Take a look at the master rep...notice the tail at the end which is after Creo makes the download(I'm starting with no objects in the workspace and letting Creo call for objects from the server in all three of these open sequences).  This tail is what I call "family table" wasted energy/processing.  Opening master rep with family tables is 58 seconds...without family tables the time is 38 seconds.  I haven't created Instance accelerators against this assembly, but I'm expecting the number to decrease about 20% from the 58 second number based on my other testing with IA's.  This picture is from my testing with build M160 of CP2...it's very disappointing that the simplified rep took 4.5 times longer to open than the master rep.  I've been consistantly seeing the hit be near 3 times longer.

Capture.JPG

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

I guess nobody is using Instance Accelerators?

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Just an update on my testing.  The two settings ("update_accelerator_in_verify yes" & "save_instance_accelerator saved_objects") combined seem to work pretty well.  However, I just started to test out the functionality of dm_upload_objects automatic (default is explicit).  The problem with this new combination is that I'm experiencing a significant performance hit when verifying instances now.  The verify action is resulting in an upload to the server side workspace.  This may be intended, but I don't like it!

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Another Update - Overall, Instance Accelerators have been reliable in our environment.  However, we did have one file yesterday resulting in Creo Crashes when opening into Creo 2 M160.  We confirmed the IA caused the crash through mutlipe tests....hopefully the case we created resolves it.      

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Bill,

 

Is your team storing XAS and XPR files in Windchill?  Do you have a Windchill preference implemented to add them to your workspace automatically when downloading instances?

 

Barry

Highlighted

Re: Instance Accelerator Config Settings - save_instance_accelerator & update_accelerator_in_verify

Bill,

 

Are you still using both Update_accelerator_in_verify yes and Save_instance_accelerator config options?  

 

Have you seen any recent heartburn with IA's lately?  I'm beginning the process of evaluating them.

 

Any experience with this one?  Verify_on_save_by_default

 

Barry

Announcements