cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ModelCHECK Dictionary, user_words, dashed/hyphenated words

lscheeler
17-Peridot

ModelCHECK Dictionary, user_words, dashed/hyphenated words

ModelCHECK (MC) is returning an error that I don't know how to get rid of.  In the user_words we have the lines:

DE-ENERGIZED
DE-ENERGIZE
DE-ENERGIZES

 

Yet, Creo is returning DE as a spelling error.  Does anyone know how to not return an error when it is part of an acceptable hyphenated word?

lscheeler_0-1616022497049.png

 


"When you reward an activity, you get more of it!"
1 ACCEPTED SOLUTION

Accepted Solutions

@manjunathrv , I did not get to testing this however PTC gave a thorough explanation and determined there is currently no MC setting that can help me.  This is their response of the one previously mentioned.

 

"MC_SPELL_IGNORE_HYPHEN is designed to consider or ignore the words with hyphen, if it is set as yes, ModelCHECK will split the word and check. This option is not useful when user want to use spell check for word with hyphen and would like to consider that as single word."

"Section view names (e.g. SECTION A-A, etc) apart from technical complication was also a known reason of limitation."


"When you reward an activity, you get more of it!"

View solution in original post

9 REPLIES 9
KenFarley
19-Tanzanite
(To:lscheeler)

I'm not a modelcheck user, but based on the fact it's the "-" that seems to be botching things up, it might be a matter of how the words are entered into the user_words file. I don't know what the format of the file is, but maybe for words with non-alphanumeric characters in them (like if you wanted to tell it to stop flagging "A&A") you might have to enclose the word you want ignored in quotes or some other delimiter?

This theory is based on the requirements of the "search.pro" where if directories have spaces in them it will not work unless they are enclosed in quotes.

I tried quotes using "" and '' and neither of them work.  I did some more tests and *think* what is actually happening is that it is ignoring the hypen, treating the dash/hypen as a space and then checking both words individually to see if in the dictionary.  This is not at all what I want so am going to open a ticket.


"When you reward an activity, you get more of it!"

I added the words ENERGIZED, ENERGIZE and ENERGIZES; MC did not flag them as spell error.

manjunathrv_0-1616132026447.png

 

Chris3
19-Tanzanite
(To:manjunathrv)

@manjunathrv you must also have DE added to your dictionary then too right? I think this is @lscheeler's point - he doesn't want to add DE to the dictionary.

 

PTC is making some model check improvements in Creo 8 so if you get your ticket in maybe they will consider making this change for you.

lscheeler
17-Peridot
(To:Chris3)

@manjunathrv , thanks for the test, however, @Chris3 is right.  There is no question whether the user_words dictionary works without hyphenated words so if you wanted to test what I am trying to do you have to add the entire hyphenated words:

DE-ENERGIZE

DE-ENERGIZED

DE-ENERGIZE

 

@Chris3 I submitted a PTC case last night so we will see what they come up wtih.


"When you reward an activity, you get more of it!"

Yes, you are right @Chris3 I added words with DE and now MC throws error.

But already DE is added to default dictionary, so just adding ENERGIZE to the user words should work fine.

I guess this is your PTC Case @lscheeler :

https://www.ptc.com/en/support/article/CS250827?

 

That actually was not my case but PTC referred me to it.  I Have not tested this yet as to what else it might affect.

 

I will try to report back after I do testing but unfortunately I am not able to test it right now.  If anyone tests this it would be great if you could please post your results here.


"When you reward an activity, you get more of it!"

@manjunathrv , I did not get to testing this however PTC gave a thorough explanation and determined there is currently no MC setting that can help me.  This is their response of the one previously mentioned.

 

"MC_SPELL_IGNORE_HYPHEN is designed to consider or ignore the words with hyphen, if it is set as yes, ModelCHECK will split the word and check. This option is not useful when user want to use spell check for word with hyphen and would like to consider that as single word."

"Section view names (e.g. SECTION A-A, etc) apart from technical complication was also a known reason of limitation."


"When you reward an activity, you get more of it!"

View solution in original post

Announcements