cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Modifying Sketcher Options

cedroneg
6-Contributor

Modifying Sketcher Options

Hello,

 

I am trying to modify my sketcher settings to always show 4 decimal places when I am modeling parts. However, when I change the option below to 4 decimal places and then export the new configuration file, it goes back to 2 decimal places after restarting creo. How can I make it not reset?

decimal places.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Make sure it's named config.pro, not currentsession.pro or whatever Creo saves it as.

 

Does your company use a config.sup file?  Look for one in the text folder in the install directory.  By default it's here:

 

C:\Program Files\PTC\Creo 3.0\M150\Common Files\text

 

Of course, if you're using Creo 4 it'll be Creo 4 and you might be running a different build.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

View solution in original post

4 REPLIES 4

Where are you saving the configuration file and under what name?

 

Creo will read files named "config.pro" from the following folders, in order:

 

  • The text folder of the installation directory
  • The user's "Home" directory, as defined by Windows
  • The folder specified in the "start in" field in the shortcut used to launch Creo.

If not named properly or in one of those folders, it won't load.

 

Also, if another config.pro file with the option set to 2 decimal places is loaded after, it will take precident.

 

Lastly, there is a special configuration file named config.sup that must be loaded from the folder of the installation directory.  If it exists and it has the option set to 2 decimal places, it will prevent you from resetting it to 4.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
cedroneg
6-Contributor
(To:dgschaefer)

I am saving the file in the start in field of the creo shortcut

Make sure it's named config.pro, not currentsession.pro or whatever Creo saves it as.

 

Does your company use a config.sup file?  Look for one in the text folder in the install directory.  By default it's here:

 

C:\Program Files\PTC\Creo 3.0\M150\Common Files\text

 

Of course, if you're using Creo 4 it'll be Creo 4 and you might be running a different build.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
cedroneg
6-Contributor
(To:dgschaefer)

Thank you! 

I went to that location and just replaced the config.pro file in there with my new one.

Announcements