Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Parametric.exe will not run


Parametric.exe will not run

We just recently updated to Creo 2.0 M100 from M070 and ran into one problem. When you try an run the parametric.exe in the bin directory nothing happens. Same for simulate.exe and creosysmon.exe. Unless I'm mistaken, running the executable should give you the option of choosing all the psf files that you had created when installing the software. I believe that for each psf file it also creates a batch file that runs the executable with the psf and skips the list. Running those batch files directly do work.


I've been working with PTC on this and the only solution they gave me was uninstall everything and start fresh. Since this is a server install with multiple users running Creo from it, that is not a convenient way of troubleshooting this.


Has anyone else run into this issue?

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Accepted Solutions

I believe I have solved the issue. The aps_ui_default_resources.dll in PTC\Creo 2.0\Parametric\text\complied_resources directory was not updated when going from M070 to M100. I replaced the dll with one from a working install and everything seems to be running like it should.

View solution in original post

22-Sapphire I

Hi Justin,

Possibly this is due to incomplete installation of Creo Parametric, look for xtop.exe in <Install Location>\Creo 2.0\Common Files\M100\x86e_win64\obj. If it is not available, uninstall and reinstall Creo 2.0

I hope this will help you.

xtop.exe is there. I did run the program Beyond Compare on that install compared to another install that is working and all the files in the working one DO show up in the one that is having issues as well.

This makes me think that a file may have not been correctly updated when going to M100?

22-Sapphire I

As it is not starting with parameteric.exe, can you make a try with parametric.bat. Sometimes .exe’s may fail to start but works well with batch files.

The parametric.bat works but doesn't take you to the list of options to select different psf's. It just opens a foundation. Are you saying that it is normal for the exe to fail in this situation? I have other installs set up the exact same way and all of those work correctly when running the exe.

I believe I have solved the issue. The aps_ui_default_resources.dll in PTC\Creo 2.0\Parametric\text\complied_resources directory was not updated when going from M070 to M100. I replaced the dll with one from a working install and everything seems to be running like it should.

I've changed that file you mentioned "aps_ui_default_resources" and I've already reinstalled several times all the PTC products and still can't get Parametric started via .exe.

Is there any other solution besides changing the shortcut from .exe to .bat ?



you can launch Creo 2.0 using parametric.bat and you are not able to launch Creo 2.0 using parametric.exe ?

It's strange because parametric.bat is calling parametric.exe.

Marin Hanak

Martin Hanák

In this case it's the Creo 3.0 M020, but yes, that's what happens.

Maybe it's missing its argument "parametric.psf" ?


can you show me the contents of your parametric.bat file ?

Martin Hanak

Martin Hanák

This is what the parametric.bat file has:

@echo off

"C:\PTC\Creo 3.0\M020\Parametric\bin\parametric.exe" "C:\PTC\Creo 3.0\M020\Parametric\bin\parametric.psf" %*


try to create the shortcut to C:\PTC\Creo 3.0\M020\Parametric\bin\parametric.exe on your desktop, put %TEMP% into Start in field and double-click the shortcut.


  • I use C:\PTC as root directory for all ProE/Creo installations. When I install Creo 3.0 M020, I use C:\PTC\Creo3_M020 as installation directory. So my path to parametric.exe is C:\PTC\Creo3_M020\Creo 3.0\M020\Parametric\bin\parametric.exe.
  • parametric.exe must be able to find parametric.psf and launch Creo successfully, I always create parametric.exe shortcut on mu desktop

Martin Hanak

Martin Hanák

Thanks for the tips, unfortunately it didn't worked.

If I go to the folder "C:\PTC\Creo 3.0\M020\Parametric\bin" which is where the parametric.exe is, it doesn't start as well.

Any other thing I can try?


unfortunatelly I don't have any other tip. On my Windows 7 PC, doubleclicking parametric.exe in "C:\PTC\Creo 3.0\M020\Parametric\bin" launches Creo 3.0 successfully.

Martin Hanak

Martin Hanák

I continue using the parametric.bat file.

I hope someone has some solution to share.

Thank you for the help.


the last tip. Check registry settings as shown in

Martin Hanak

Martin Hanák

Didn't worked too

I discovered that if go to folder by 'cmd' prompt and write 'parametric.exe' it can run from there, but only from windows console.


1.) TEST: open Command prompt window, enter full path to parametric.exe (move parametric.exe from Windows Explorer on Command prompt window) and press ENTER

What happened ?

2.) CHECK: open Command prompt window, type PATH and press ENTER, show us the output of the command

Martin Hanak

Martin Hanák
23-Emerald II


Have you checked to see if it is a graphics issue? Especially if this is your first time running Creo on your computer.

In your file, add the line

graphics win32_gdi


My work colleague has the exact same computer as me and they were delivered at the very same state and his parametric works just fine.

I've tested but it didn't worked too.

Creo has only worked once, after that I've been always forced to use the bat file.

Thanks Steve

Try swapping the graphics cards. It is possible you have a hardware defect.

This is a brand new Asus laptop, same as my colleague. But I've tried but start it just with Intel graphics instead of nvidia and it didn't worked.


Your step one worked with both parametric.exe file in the instalation folder and on the desktop shortcut (I have the shortcut starting in a custom folder). I can launch it trough prompt.

My PATH has the following:







C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;

C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;





C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;

C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;

C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;

C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;

C:\Program Files\Intel\WiFi\bin\;

C:\Program Files\Common Files\Intel\WirelessCommon\;

C:\Program Files\Java\jdk1.7.0_71\bin;C:\PTC\Flexnet\bin

EDIT: I don't know if this helps but when I close Parametric my task manager has one process called "PTC Creo 3.0 from PTC (32 bits)" which points to "C:\PTC\PTC Portmapper\i486_nt\obj\portmap.exe"

Thanks in advanced


inside the PATH contents, I don't understand C:\PTC\UTILIT~1\MKSTOO~1\* entries. Did you install MKS Toolkit ?

My suggestion:

  • uninstall all Creo 3.0 M020 items (Parametric, SImulate, ...)
  • uninstall MKS Toolkit (if it was installed during Creo 3.0 M020 installation)
  • uninstall Creo Platform 3.89
  • uninstall PTC Quality Agent
  • uninstall Portmapper (if you see it in the list)
  • install Creo 3.0 M020 from the scratch in C:\PTC\Creo3_M020 empty directory to prevent mixup with other installations
  • select Parametric item, only during installation ... deselect other automatically selected items, scroll down to see all items

Also check whether CREOAPP_DIRECTORY variable is defined:

  • open Command prompt window, type set CREOAPP_DIRECTORY and press ENTER key

What Windows version is installed on your laptop ?

On other laptop, is it Creo installed in the same installation directory ?

Martin Hanak

Martin Hanák

Yes, I'll need toolkit to develop for Creo.

I've reinstalled Creo multiple times. Maybe I should try to install all that I need 1 by 1?

I haven't that variable defined, neither has my colleague.

I'm running Windows 8.1 Pro.

Not sure if you have the ability to do so, but try using Beyond Compare to see if a file is missing from the install. I tried reinstalling everything at once and then one thing at a time and neither worked until I realized the issue with that file. You can get a try version of Beyond Compare 4. On your colleaguse's laptop, share out the program file folder for Creo. Then map it to your laptop as a drive. When you open Beyond Compare you can select compare folders. Select your programs file folder and his and run the compare. It will tell you what files he has that you are missing (if any).

I spent well over 60 hours reinstalling and working with PTC to find that taking 5 minutes to run the compare gave me the reason why it wasn't working. It may not help you, but taking 10 minutes to give it a shot may be worth it or at least give you a better idea of the root issues.

I compared both folders and almost every file was different. I replaced my folder for his (and saved a copy) and the problem remains.

It seems it has no solution. I'll just keep on using the bat file to launch the program.

Thank you all for your tips.

Best regards

Have you compared the registry?

Is there any fields I should check more carefuly?

Thanks David


what if the problem is related to your user account ? Try to login as different user.

Martin Hanak

Martin Hanák

yep, it didn't worked too.

It's okay though, I got used to this.

Thanks anyway

Top Tags