cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Setting up modelCHECK conditions

ptc-1226817
1-Newbie

Setting up modelCHECK conditions

I've set up ModelCHECK and everything is work as I want it too. However, I ran in to a bit of a snag. I have this condition for pipe parts unfortunately modelCHECK is not recognizing the model type condition for pipes and this is a condition that’s listed in the ModelCHECK guide. Now am I doing something wrong? Is there a work around or a fix?

IF (MODEL_TYPE EQ PRT_PIPE) config=(check/ula_checks.mch)(start/ula_piping_start.mcs)(constant/inch.mcn)(status/sample_status.mcq)


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
4 REPLIES 4

Hi Michael,

I searched this quickly but I found this.

https://www.ptc.com/appserver/cs/view/solution.jsp?n=CS102512&source=tssearch

Let us know if it is applicable.

Thanks for the reply. However, the link you provided doesn't help me out. After researching more on this subject I came to find out that modelCHECK doesn't recognize the condition for MODEL_TYPE EQ PRT_PIPE. If I'm wrong please correct me.

I looked into this further. SPR 1194232 led to an update in Creo Parametric's Help Center.

A part created in the piping module is not recognized as a "PIPE" part type in the same way as Sheetmetal, Skeleton, Harness, etc. will be. This condition setting value is intended to look for pipe features in a part, not for a pipe model type.

Document CS102512 should have indicated that the Help Center was updated to clarify the PART_PIPE value in the following sections:

Both sections contain the note: "PRT_PIPE is not for piping systems created using the Piping module but only for models that contain pipe features." The note was added to Creo Parametric 2.0 so if you're using the Pro/ENGINEER Help Center you will not see the changes.

I'll rework CS102512 because it is currently unclear. If this doesn't explain what you're seeing, I recommend you open a case with Technical Support.

That helped. Unfortunately we use the Piping module to create all of out pipes. So if modelCHECK picks up on pipe feature how can I configure modelCHECK to recognize pipes that were made within the Piping module?

Top Tags