cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Spekan sBatch Troubles

ptc-2151062
1-Newbie

Spekan sBatch Troubles

Hello all,

I am new to the Spekan sBatch tool (version 4.1) and was hoping some of you veterans might be able to help me out.

As a simple test, I tried to do the following:

-Use a .prt on my desktop to run a simple action on

-Have the tool write a mapkey that I can load into Creo

I can generate the spekan.pro file without issue, and I can load it into Creo as well. When I look at my mapkeys in creo, I show four additional mapkeys that were loaded in from the spekan.pro file:

-batchclose

-batchexit

-batchsave

-run

These are in addition to my mapkeys in my config file loaded during creo startup.

However, when I excecute the "-run" mapkey, nothing happens. The message area in Creo says "Playing mapkey -run...".

Any ideas as to what might be wrong?

Also, I noticed the tool produces the spekan.pro file AND another file called sBatch.pro. What is this file used for?

I have attached my spekan.pro file.

Regards,

Andri

Creo 1.0 M050

Windchill 10.0 M030


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
2 REPLIES 2
Jose_Costa
5-Regular Member
(To:ptc-2151062)

Hi Andri,

Sbatch 4.1 works only in Wildfire, it hasn´t been updated to Creo.

The mapkeys from wildfire also don´t work in Creo, they have to be recreated.

You can use Creo Distributed Batch (Dbatch) to run a mapkey in multiple files, it´s free and it comes with Creo installation files. Here´s an example video:

http://communities.ptc.com/videos/3303

Some tasks come already defined like importing, exporting, plotting, etc.. You don´t need mapkeys for these.

Hope it helps.

Jose

Jose,

Clearly an oversight on my part - I didn't think sBatch cared if I was running Creo vs. WF, but obviously it does.

Since I still have Creo Elements 5.0, I tried running a sBatch mapkey with it, and it worked just fine!

I've tried using Creo Distributed Batch, and it worked - but the process was so slow and inefficient (for a PDF export of multiple .drws, Creo started and shutdown in between every export), in the end taking much longer than if I manually open each drawing and do a PDF export on each item. See this discussion. That's why I am looking for another way to do this.

Do you know if Distributed Batch allows you to generate a .pro mapkey file that can then be loaded into a running session of Creo, similar to how sBatch does it?

There has got to be a way to efficiently and "relatively" easily export hundreds of drawings, using Creo and Windchill!

Thanks for your help,

Andri

Announcements