Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

The Most Worthless Error Message


The Most Worthless Error Message

This is a gripe not a question. I get this sometimes while trying to mesh complex geometry.


The requested shape change failed because it results in

the deletion of the highlighted geometry. This geometry has

an association that cannot be deleted. "

1) No geometry is highlighted!

2) What does it mean?

I have slowly come to learn that this message indicates that certian idealizations can not share the same point. There is no indication where the problem is located and what can not share a point. This measage predates WF and it still exsists in Creo.

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

I've found that most ALL of the PTC family of error messages are best.

I've recently found that some Mechanica entities (specifically, Contact Interfaces in 2D) can become deleted if the geometry changes during a Sensitivity Study (such as the two edges moving too far apart) and this causes the run to abort.

I'm currently whinging to PTC about this, and some other Mechanica quirks, via Calls.

I'm getting the same error. Their axisymmetric analysis is a headache. No real help as to what the error means or why it came about. I'm going through a simple cylindrical heat analysis, and right now I'm considering writing my own code.

Pro E's simulation is poorly done. We're moving to Creo soon, and if it continues to be a problem, I'm talking the company into switching software. The benefits of Pro E don't apply to small assemblies, and we don't need this time cost.


In general this error message appears when you intend to run analysis on a non-solid model.

For instance

  1. a shell model, where you look only at the central fiber of the material. If in Creo you put a constrain on the surface that will not be in the shell model (because you collapsed the solid) you getr the message mentioned.
  2. Likewise this can happen in axisymmetric.
  3. Another possibility is a load on the surface that is between two parts.When making a mesh, the surface internally in simulate no loger exists, so it has to delete the load, which it won't. Make a surface region to work around this.

Just watch where you put your constraints and loads.


I got the same error message and, for my particular case, found out what the problem was. (Short answer: make sure all model geometry is selected under Edit -> Mechanica Model Setup) Here's a description of my problem:

I had an assembly with two parts. I did the first-time Mechanica Model Setup by selecting the two component surfaces (I'm doing an axisymmetric). Everything ran fine. I then modified the way the components were defined in ProE (Standard Application, not Mechanica). After fixing everything (or so I thought) that broke in Mechanica as a result of my assembly changes, I got that error message. I finally figured out that I had to go back into Edit -> Mechanica Model Setup. Only one of my surfaces was selected. After selecting both surfaces, I got the model to run without error messages!

I later added a third component to my assembly and added forces and contacts in Mechanica. At first, I did not add this new geometry in Mechanica Model Setup. I got the same error message. After adding the new surface in Mechanica Model Setup, it works with no error message.

Hope this helps others. Good luck.

No that's not hte most useless error message, this one is more useless:

An engine disk write error has occurred, probably due to

insufficient disk space or directory/file permissions.

Mainly becuase the error is not due to insuifficient disk space or directory/file permissions!

PTC won't looki into what the problem is without all the files and due to the nature of the project they can't have the files.

Bumping this thread because I've hit it again.

I'm trying to mesh a gear casing for thermal analysis, so I've got a heat load on most of the interior surfaces and a convection condition on most of the external one.

The casing (imported geometry) has a lot of fairly slender surface patches, and it would appear that AutoGEM wants to delete lots of them (according to Interactive Diagnostics). It isn't allowed to do this because there's a load or constraint attached (even if suppressed...).

Are there any AutoGEM settings I can change to stop it doing this? I've already disable 'move or delete existing points'. Will it work if I delete my loads/constraints, mesh the volumes (saving the mesh) and then recreate the boundary conditions (tedious)?


Look under Autogem, change the geometry tolerance settings to absolute and use values appropriate for your model, your surfaces will no longer be deleted.

good luck!


Picture below (in dutch, but most likely clear enough) is from a training I developed.


Top Tags