cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can not open the extension manager

qzhang
1-Newbie

Can not open the extension manager

I import an extension into TW, and I want to delete that, but I can not access to manage list as follows.

And I tried to delete from extension fold, then  restarted the server, but still can not import new one.

I have no idea how to delete the extensions clearly.

10 REPLIES 10
ankigupta
5-Regular Member
(To:qzhang)

Hi qiqiang Zhang​,

What is the ThingWorx version? Database type? OS? tomcat version?

Is it a newly installed version or upgraded from previous version.

If it was upgraded; was the upgrade process of export and then import to new version was followed?

If you are not able to view the Extension Manager Page; it is probably because their is some error in some extension.

You can try following to resolve this issue (Only if it's not a Production instance).

Take an export of all entities and data. In a fresh install of ThingWorx; import all the extensions that existed in the previous version. Then import the entities and the Data.

I just upgraded tw from 7.2 to 7.4 , progress in unbantu, tomcat is 8.0.33,

and I can access to by [server address]/Thingworx/Runtime/index.html#master=ThingWorxMonitor&mashup=ExtensionManagerListing but not the manage icon。

qngo
4-Participant
(To:qzhang)

It's a bug of TWX 7.4 apparently. On the previous version, the link of Extension Manager is

[server address]/Thingworx/Runtime/index.html#master=ThingWorxMonitor&mashup=ExtensionManagerListing

ankigupta
5-Regular Member
(To:qngo)

Hi Quang-Dung Ngo​,

[server address]/Thingworx/Mashups/ExtensionManagerListing

should actually redirect to

[server address]/Thingworx/Runtime/index.html#master=ThingWorxMonitor&mashup=ExtensionManagerListing

automatically.

But it does not

qngo
4-Participant
(To:qngo)

Hi Ankit, normally yes. But it's not the case on TWX 7.4

ankigupta
5-Regular Member
(To:qngo)

Hi Quang-Dung Ngo​,

I have ThingWorx 7.4.0 on my local instance and it works fine for me. I get redirected to [server address]/Thingworx/Runtime/index.html#master=ThingWorxMonitor&mashup=ExtensionManagerListing on opeing the Extension Manager page.

Maybe some setting changed on your instance after the Entity/Data import.

So, does all the redirection (Mashup to Runtime) not working for you in ThingWorx 7.4

Did you check the extension manager before importing Extensions and entities/Data?

qngo
4-Participant
(To:ankigupta)

The Extension Manager worked fine before updating to 7.4. Here are the errors on TWX 7.4 when I open the Extension Manager from the menu.

Errors:

2017-03-30 17:16:24.869

ERROR

[context: com.thingworx.webservices.context.HttpExecutionContext@5b7bc3e7][message: Redirect failed]

Administrator

c.t.w.BaseService

http-nio-8080-exec-4


2017-03-30 17:16:24.868

WARN

[SECURITY FAILURE Anonymous:null@unknown -> /ExampleApplication/IntrusionDetector] Bad redirect location: /Thingworx/Runtime/index.html#mashup=ExtensionManagerListing

Administrator

IntrusionDetector

http-nio-8080-exec-4


2017-03-30 17:16:24.867

WARN

[SECURITY FAILURE Anonymous:null@unknown -> /ExampleApplication/IntrusionDetector] Invalid input: context=Redirect, type(Redirect)=^\/test.*$, input=/Thingworx/Runtime/index.html#mashup=ExtensionManagerListing

Administrator

IntrusionDetector

http-nio-8080-exec-4


2017-03-30 17:16:24.867

ERROR

[SECURITY FAILURE Anonymous:null@unknown -> /ExampleApplication/HTTPUtilities] Bad redirect location: /Thingworx/Runtime/index.html#mashup=ExtensionManagerListing

Administrator

HTTPUtilities

http-nio-8080-exec-4

There are also other errors that I only see on TWX 7.4 after updating:

2017-03-30 18:19:08.225

WARN

Failed to get any reservations

SuperUser

c.t.s.s.f.e.ReservationReclaimer

pool-11-thread-1


2017-03-30 18:19:08.224

WARN

[c3p0] Another error has occurred [ org.postgresql.util.PSQLException: This connection has been closed. ] which will not be reported to listeners!

SuperUser

c.m.v.c.i.NewPooledConnection

pool-11-thread-1


2017-03-30 18:19:08.224

ERROR

[message: [2,002] No connection. Contact the administrator.]

SuperUser

c.t.p.p.PostgresModelExceptionTranslator

pool-11-thread-1


2017-03-30 18:19:08.223

WARN

[c3p0] A PooledConnection that has already signalled a Connection error is still in use!

SuperUser

c.m.v.c.i.NewPooledConnection

pool-11-thread-1


I already opened a support case for all these errors (and other ones). I'm still waiting for answer.

qzhang
1-Newbie
(To:qngo)

Thanks

ankigupta
5-Regular Member
(To:qzhang)

qiqiang Zhang​,

Based on Quang response:

try to change the url from

[server address]/Thingworx/Mashups/ExtensionManagerListing

to

[server address]/Thingworx/Runtime/index.html#master=ThingWorxMonitor&mashup=ExtensionManagerListing

Announcements