cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Composer loading forever

SOLVED
Newbie

Composer loading forever

So i just reinstalled Thingworx 7.3 Postgres. This is running on a VM and the Composer loads correctly from the web browser in the VM.

When connecting from my physical machine, I can connect to the Tomcat page, however when loading the composer it just loads forever after getting the jsessionid.

This was fixed initially by opening an incognito tab, however this no longer works. I've also tried Internet Explorer and chrome.

Any help is appreciated as we want to have access for a few users in multiple locations and need the composer to load!

Thanks

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Composer loading forever

The only thing I'm seeing in the new logs is this  "Server WebSocket closed unexpectedly and has already been unregistered from Server Endpoint" as if you have edge devices.

Do you have any type of security/ssl setup /firewall that might be the problem when reaching your vm from a local machine?

15 REPLIES 15

Re: Composer loading forever

Hi Matthew, have you checked the tomcat logs for more info? Do you have HTTPS enabled? I think it could also be worth checking the debugger tool from the web browser at the Network section to see if it's somehow getting blocked.

Re: Composer loading forever

Hi Matthew Felton​,

In addition to what Sushant said please also check the ThingWorx Application logs.

Re: Composer loading forever

I checked these myself, and i cant see anything that indicates a problem, hopefully you guys can spot something?

Re: Composer loading forever

Matthew, are you running Tomcat 8.5.11? (it's not yet officially supported) Additionally are you seeing this on all the web browsers available on your machine? Is there a reverse proxy configured on the VM? I think it could be worth a try checking the Network in debugger window (F12 for Chrome) just to see if there are any errors on the network itself

Re: Composer loading forever

So i checked the network, there doesn't appear to be any errors but Combined.7.3.3-b67.20170320.031054.00743.js isn't finishing? I have also attached the HAR file for you to view.

I've been running this version of Tomcat for a while & this is the only connection issue ive had, This setup worked perfectly with Thingworx 7.2 H2, so I think its unlikely a tomcat issue?

Re: Composer loading forever

Matthew, in your logs I see you are running [server = Apache Tomcat/8.5.11]. Our product is not supported with 8.5 tomcat, only 8.0.x, where X is at least 33. Typically it wouldn't work with any 7.x platform version, but even if it did with 7.2, that's more of a rare exception to the rule. Additionally, please note that  8.0.39 and later versions of Tomcat sometimes use an extra pair of curly braces in the responses and in result, the thingworx application might be unstable as witnessed  on multiple occassions. We strongly recommend to stay within 8.0.33 and 8.0.38 range (per our document guide, tomcat 8.0.33 was the one we tested with).

Please downgrade the tomcat and report back if the issue still persists.

Re: Composer loading forever

Okay, installed now with Tomcat 8.0.33 and same problem still persists?

Highlighted

Re: Composer loading forever

Do you have Kinex installed? If so, did you install it as an extension? Do you have Kepware on the same machine?

Also could you please attach a screenshot of your Tomcat Java tab configuration.

Re: Composer loading forever

Yes Kinex is installed, as an extension, Kepware is on a seperate VM.