cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community email notifications are disrupted. While we are working to resolve, please check on your favorite boards regularly to keep up with your conversations and new topics.

DataTable not running

Tomellache2B
14-Alexandrite

DataTable not running

Hi Community,

 

Please can someone assist me with this?

I have created a data table and given it a datashape.  When I go and see the mashup, I'd expect to at least see the columns appear without any data. 

However there are no columns. When I run getDataTableEntries, I get a script this error: 'dataTable is not running'. 

What does this mean? how does can I remedy this?

 

Regards,

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Tomellache2B
14-Alexandrite
(To:jensc)

Hello, 

 

I the error log was complaining about the persistent provider on the datatable. Previously it was set to influx DB so I changed it to Thingworx persistent provider, then the columns appeared on the datatable mashup. 

Thank you.

View solution in original post

2 REPLIES 2

Hello,

 

Did you try running the "RestartThing" service?

I don't see that you should have to, but you never know.

Also, is there any error messages in the logs that might help us?

 

Regards,

Jens

Tomellache2B
14-Alexandrite
(To:jensc)

Hello, 

 

I the error log was complaining about the persistent provider on the datatable. Previously it was set to influx DB so I changed it to Thingworx persistent provider, then the columns appeared on the datatable mashup. 

Thank you.

Top Tags