cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Error occurred while validating HTTP header: cookie

SOLVED
Highlighted
Level 1

Error occurred while validating HTTP header: cookie

Hi,

I am getting the below error continuously in application log. I am using thingworx version 7.1.2-b50.

Error occurred while validating HTTP header: cookie

We are getting serious performance issues in production. Is this error causing the problem.

Thanks

Pai Chung

Aanjan Ravi

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error occurred while validating HTTP header: cookie

Raju, the error you're getting is related to the browser cookie not validating correctly on our regex. The validation.properties (under ThingworxStorage/esapi) has a section called 'Validator.HTTPHeaderValue_cookie' where you can add extra characters to allow them through.

With that being said, it should not cause any performance issues per se, as this only affects logging.

3 REPLIES

Re: Error occurred while validating HTTP header: cookie

Raju, the error you're getting is related to the browser cookie not validating correctly on our regex. The validation.properties (under ThingworxStorage/esapi) has a section called 'Validator.HTTPHeaderValue_cookie' where you can add extra characters to allow them through.

With that being said, it should not cause any performance issues per se, as this only affects logging.

Re: Error occurred while validating HTTP header: cookie

I got it. So can we do anything that improves the performance.

Re: Error occurred while validating HTTP header: cookie

Hi @Aanjan,

 

I have updated the property "Validator.HTTPCookieValue=^[a-zA-Z0-9-\\\/+=_%;\.| ]*$" and my cookie id was "JSESSIONID=5D443A9AACEABC3C44B7C4883B142D26". The Id seems to match the regex i had checked, but i can still see "Error occurred while validating HTTP header: cookie" in the logs. 

 

Based on  this article, i had changed the platform.settings file as below,

 

{
"PlatformSettingsConfig": {
		"BasicSettings": {
			"HTTPRequestHeaderMaxLength": 10000,
			"HTTPRequestParameterMaxLength": 10000
		}
	},
	"PersistenceProviderPackageConfigs": {
		"PostgresPersistenceProviderPackage": {
			"ConnectionInformation": {
				"jdbcUrl": <jdbc:postgresql://postgresql URL/thingworx>,
				"password": "password",
				"username": "twadmin",
				"maxPoolSize": "15000",
				"minPoolSize": "500"
			}
		}
	}
}

But the issue persists. Please advice.

 

Thanks and Regards

Saran