cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Hyperlink in Grid Advanced (Thingworx 8.5.2)

SOLVED
VS_9760165
Amethyst

Hyperlink in Grid Advanced (Thingworx 8.5.2)

Hi ,

I have a Grid Advance in Mashup , running on Thingworx 8.5.2 , i had to add Hyperlink as Column Value. and i added it using Column Base Type as 'Hyperlink' but at runtime in grid its not Clickable. please see below screen..

 

VS_9760165_0-1608811883628.png

Thanks

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Hi @VS_9760165 ,

It may be due to grid settings, Please follow below steps

  1. Click on grid
  2. Click on Configure and Bindings
  3. Select Link column
  4. Click on Column Renderer & State Formatting tab
  5. Select Renderer : HYPERLINK
  6. Select Other parameters as shown in the image below
    • Capture1.PNG

       

View solution in original post

Tags (1)
5 REPLIES 5

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Hi @Ciprian-Traian 

 

above post is more about Checkbox but they have provided below Answer for Hyperlink . see below screenshot of that post..and already i did the same but not clickable.

VS_9760165_0-1608813817127.png

 

Thanks

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Create a field/column with Hyperlink as datatype and bind data to advanced grid. The Link will appear as below

Ashritha_0-1608816932387.png

When view is clicked , navigates to target link .

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Hi @Ashritha ,

I have added field like below in infotable..

VS_9760165_1-1609735928984.png

In datashape have added Link Field with Basetype Hyperlink as below...

VS_9760165_2-1609736042034.png

getting output as..

VS_9760165_3-1609736251878.png

 

But still not clickable...its highlighting complete row when i move cursor to row as in above 1st post . what do i need ?

Thanks

Tags (1)

Re: Hyperlink in Grid Advanced (Thingworx 8.5.2)

Hi @VS_9760165 ,

It may be due to grid settings, Please follow below steps

  1. Click on grid
  2. Click on Configure and Bindings
  3. Select Link column
  4. Click on Column Renderer & State Formatting tab
  5. Select Renderer : HYPERLINK
  6. Select Other parameters as shown in the image below
    • Capture1.PNG

       

View solution in original post

Tags (1)
Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.