cancel
Showing results for 
Search instead for 
Did you mean: 
Security Alert Log4j Security Vulnerability. Click here to know more.
cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to connect IoT hub thing

Sumeet
4-Participant

Not able to connect IoT hub thing

I have been trying to connect the Azure IoT hub to my Thingworx platform. I have followed every steps in documentation and ab able to get cx-server in platforms monitoring>connection server. But the thing which I have created is not able to connect to the Iot hub connector.

ThingWorx platform: 9

Thingworx-Azure-IoT-Hub-Connector-4.2.0.4 

1 ACCEPTED SOLUTION

Accepted Solutions
Sumeet
4-Participant
(To:PaiChung)

Hii PaiChung,

Thanks for the reply after resetting the AzureIoTHubThing it connected.

 

View solution in original post

4 REPLIES 4
PaiChung
21-Topaz II
(To:Sumeet)

What sort of output are you getting in the different logs? Both on the connector side and within ThingWorx?

Sumeet
4-Participant
(To:PaiChung)

Hello PaiChung,

Attaching cxserver and thingworx log files  and am connecting to platform without ssl.

kindly help on this.

 

PaiChung
21-Topaz II
(To:Sumeet)

I can't say for sure what your  issue is.

on the one side it seems to run out of 'buffer space' and you are losing updates.

In the other log it is talking about some permissions issue limiting what can be done.

I'd try to tackle the permissions issue first.

You then may have to do some 'reset' to potentially clear out the buffer build up.

Sumeet
4-Participant
(To:PaiChung)

Hii PaiChung,

Thanks for the reply after resetting the AzureIoTHubThing it connected.

 

Announcements